Bug 886944 - RHEVM-CLI: wrong response (error: action status "pending") for suspend VM
RHEVM-CLI: wrong response (error: action status "pending") for suspend VM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Michael Pasternak
Barak Dagan
infra
:
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-13 11:15 EST by Barak Dagan
Modified: 2016-02-10 14:44 EST (History)
10 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Bug Fix
Doc Text:
When suspending a VM an incorrect error message was being displayed: 'error: action status "pending".' The system state of 'pending' was not being recognized and triggered the error message. This state is now recognized by the system and 'pending' is displayed when a suspend request on a VM is executed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:29:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barak Dagan 2012-12-13 11:15:26 EST
Description of problem:
When suspending running VM: "action vm VM-3 suspend", the response is:
'error: action status "pending".', but the VM gets to suspended status afterall (after passing saving_state)

# list vms --query 'name=VM-0' --show-all | grep status
status-state              : saving_state
# list vms --query 'name=VM-0' --show-all | grep status
status-state              : suspended


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
[RHEVM shell (connected)]# action vm VM-3 suspend


error: action status "pending".



Expected results:
Get success when the VM entered suspended state (like in create)

Additional info:
Comment 1 Oded Ramraz 2012-12-13 11:55:14 EST
I see the same error for export VM command :

RHEVM shell (connected)]# action vm 0c373c97-0a72-4e4e-a9fd-7d7d906e9531 export --storage_domain-id 1a0029a9-2cf4-4995-9951-d0872227c6c9

error: action status "pending".
Comment 2 Michael Pasternak 2012-12-16 03:52:33 EST
(In reply to comment #1)
> I see the same error for export VM command :
> 
> RHEVM shell (connected)]# action vm 0c373c97-0a72-4e4e-a9fd-7d7d906e9531
> export --storage_domain-id 1a0029a9-2cf4-4995-9951-d0872227c6c9
> 
> error: action status "pending".

Barak,

i need some help from you on this:

1. can you please help me reproducing 'pending' status for me?
2. can you please run same action in rest-api and add a response to this BZ
(when actions status is 'pending')
Comment 3 Michael Pasternak 2012-12-24 04:00:37 EST
Barak,

Either provide reproducer or close this bug.
Comment 4 Oded Ramraz 2012-12-24 04:03:47 EST
I managed to reproduce it in 2 different flows:

1.
RHEVM shell (connected)]action vm 0c373c97-0a72-4e4e-a9fd-7d7d906e9531 export --storage_domain-id 1a0029a9-2cf4-4995-9951-d0872227c6c9


error: action status "pending".

2. It happen every time when trying to suspend VM :

[RHEVM shell (connected)]# action vm VMNAME suspend


error: action status "pending".


(In reply to comment #3)
> Barak,
> 
> Either provide reproducer or close this bug.
Comment 6 Michael Pasternak 2012-12-25 08:11:00 EST
http://gerrit.ovirt.org/#/c/10365/
Comment 7 Oded Ramraz 2013-01-24 09:37:55 EST
Verified sf4

[RHEVM shell (connected)]# action vm 816e3fcf-c157-4b9a-bff3-058a2b42e1f5 suspend

id          : 80d62976-28f2-46d6-9613-8fb9ddecb05d%2Cd906a9c2-83a1-467f-9ecb-66ea810c22f5
async       : True
status-state: pending
Comment 8 errata-xmlrpc 2013-06-10 16:29:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0890.html

Note You need to log in before you can comment on or make changes to this bug.