Bug 88697 - xawtv segfaults and nothing is displayed
xawtv segfaults and nothing is displayed
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: xawtv (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-11 20:36 EDT by Alfredo
Modified: 2007-04-18 12:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-18 06:08:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Ouput from lspci -vv (5.29 KB, text/plain)
2003-04-11 20:37 EDT, Alfredo
no flags Details
Output from strace xawtv (12.69 KB, text/plain)
2003-04-11 20:38 EDT, Alfredo
no flags Details

  None (edit)
Description Alfredo 2003-04-11 20:36:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:

xawtv is running fine with vanilla kernels 2.4.20 and 2.4.21-pre5. With kernels
2.4.20-8 and 2.4.20-9 from RH it just segfaults. I've compiled xawtv_3.86.tar.gz
from bytexex.org and still segfaults (and runs fine with vanilla kernels)

Version-Release number of selected component (if applicable):
xawtv-3.81-6

How reproducible:
Always

Steps to Reproduce:
1. launch xawtv from a terminal

Actual Results:  nothing, just segfaults with no window displayed

Expected Results:  something to view :)

Additional info:
Comment 1 Alfredo 2003-04-11 20:37:41 EDT
Created attachment 91091 [details]
Ouput from lspci -vv
Comment 2 Alfredo 2003-04-11 20:38:16 EDT
Created attachment 91092 [details]
Output from strace xawtv
Comment 3 Tim Mann 2003-05-30 02:35:27 EDT
I have the same problem.  This is on a system newly upgraded from RH 7.3 to RH
9, running kernel 2.4.20-13.9, with xawtv 3.81-6.

It looks like the problem is that xawtv is unhappy with NPTL, the new threads
package.  It works if you use the following command line:

  LD_ASSUME_KERNEL=2.4.1 xawtv

Hope this helps.
Comment 4 Ngo Than 2003-08-18 06:08:59 EDT
yes, it looks like ntpl problem. You have to set LD_ASSUME_KERNEL=2.4.19 before
starting xawtv.

LD_ASSUME_KERNEL=2.4.19 xawtv

Note You need to log in before you can comment on or make changes to this bug.