Bug 886984 - Tomcat plugin incorrectly deletes Tomcat role
Tomcat plugin incorrectly deletes Tomcat role
Status: CLOSED DUPLICATE of bug 688358
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- Tomcat (Show other bugs)
JON 3.1.2
Unspecified Unspecified
unspecified Severity medium
: ---
: JON 3.1.2
Assigned To: Jean-frederic Clere
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 13:27 EST by Michal Haško
Modified: 2015-03-01 23:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-14 11:39:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Haško 2012-12-13 13:27:02 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michal Haško 2012-12-13 13:35:24 EST
Stupid bugzilla. You hit enter on a wrong text field, and this happens.

Description of problem:
Tomcat6 (possible even Tomcat7) plugin seem not to be invoking the 'save()' operation on 'Users:type=UserDatabase,database=UserDatabase' MBean.
When a user removes a tomcat role through the JON web interface, the role is still written in tomcat-users.xml. That means, that when tomcat is restarted, the role will be active again.

Version-Release number of selected component (if applicable):
3.1.2.ER4

How reproducible:
100%

Steps to Reproduce:
1. add a tomcat role in JON.
2. assert it is available through jconsole
3. assert it is present in tomcat-users.xml
4. remove the tomcat role in JON.
5. assert it is available through jconsole
6. assert it is present in tomcat-users.xml

  
Actual results:
role is still present in tomcat-users.xml, but not available in jconsole

Expected results:
role should be removed from tomcat-users.xml
Comment 2 Rémy Maucherat 2012-12-14 10:17:27 EST
The plugin correctly invokes the save method on all user database operations, but the said user database default configuration is to be read only (and so refuses to do the save). This needs to be configured by the user if he wants to be able to edit the user database dynamically, and is an obvious safety feature.
Comment 3 Rémy Maucherat 2012-12-14 11:39:03 EST
Unless I missed something, it's a duplicate, the bahvaior is a bit weird but that's what Tomcat does by default.

*** This bug has been marked as a duplicate of bug 688358 ***

Note You need to log in before you can comment on or make changes to this bug.