Bug 88705 - redhat 9 wont install with number nine video card and sgi monitor
redhat 9 wont install with number nine video card and sgi monitor
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: hwdata (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-11 22:48 EDT by Jason
Modified: 2014-03-16 22:35 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.105-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-29 01:10:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
inf for sgi 1600sw monitor (1.86 KB, text/plain)
2003-05-25 17:31 EDT, Jason
no flags Details
original inf file (39.49 KB, text/plain)
2003-05-25 17:32 EDT, Jason
no flags Details

  None (edit)
Description Jason 2003-04-11 22:48:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I am tring to install RedHat 9 on PC.  I boot the PC from CD.  I selected a 
graphical install.  The kernel starts to load and gets to the part /sbin/loader 
and then the screen blanks.  I am not totally sure if the command 
is /sbin/loader because the monitor goes blank as soon as it flashes on the 
screen.  I then tried linux text at the boot prompt, same problem.  Then I 
tried linux lowres, same problem.  I have a tyan tiger 100 S1832DL motherbaoard 
with 256MB of RAM.  I have an adaptec 2930U2 SCSI card with two 9GB hard 
drives, ID 0 and ID 1.  1 Plextor SCSI CD-ROM (ID 3).  1 3Com 905B ethernet 
card, 1 Actiontec internal PCI call waiting modem (a real modem, not a 
winmodem).  I have a Number nine Revolution IV video card with a SGI 1600SW 
monitor.  The install looks like it would continue because I pressed enter a 
few times and the CD and HD started to spin up, but I can't see anything on the 
screen.  

Version-Release number of selected component (if applicable):
anaconda-whatever is on the cd

How reproducible:
Always

Steps to Reproduce:
1.  Boot a redhat 9 disk 1
2.  Select any option
3.  The kernel text scrolls by, the text or graphical part starts but nothing 
displays on the monitor.
    

Actual Results:  The screen is blank.  The light on the monitor is flashing 
like it lost the signal from the video card.

Expected Results:  I should be able to see something

Additional info:
Comment 1 Michael Fulbright 2003-04-14 12:22:47 EDT
Try adding 'skipddc' to the command line.
Comment 2 Jason 2003-04-14 22:51:02 EDT
I tried linux skipddc and it didn't work.  I forgot to mention the native 
resolutions for this monitor are 800x512 and 1600x1200.  Do you have any other 
suggestions?
Comment 3 Jason 2003-04-29 17:18:43 EDT
I am sorry I made a typo eariler.  The native resolutions are 800x512 and
1600x1024 not 1600x1200.

Jason
Comment 4 Michael Fulbright 2003-05-12 17:50:24 EDT
Try 'linux nofb text'.
Comment 5 Jason 2003-05-14 13:43:01 EDT
Using linux nofb text I was able to install redhat 9.  My sgi 1600sw showed up
as an unknown monitor.  Can you please add support for the sgi 1600sw monitor?
Comment 6 Michael Fulbright 2003-05-20 14:49:13 EDT
I will forward this issue report to the X configuration group.
Comment 7 Bill Nottingham 2003-05-20 15:06:21 EDT
Does it show up if you run 'ddcprobe'? Do you have an INF file?
Comment 8 Jason 2003-05-25 17:01:50 EDT
Videocard DDC probe results
Description:  Number Nine Visual Technology Corporation REVOLUTION(tm) IV
Memory (MB):  32

Monitor DDC probe results
ID: SGX0640
Name: SGI 1600SW F
Width (mm): 370
Height(mm): 240

Here are the modelines that I currently use.

Section "Modes" 

	Identifier "SGI" 

ModeLine "1600x1024d32" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 7
+Hsync +Vsync 

ModeLine "1600x1024d16" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 5
+Hsync +Vsync 

ModeLine "1600x1024d08" 103.125 1600 1600 1656 1664 1024 1024 1029 1030 HSkew 1
+Hsync +Vsync 

ModeLine "800x512d32" 54.375 800 800 840 848 512 512 514 515 HSkew 7 DoubleScan
+Hsync +Vsync 

ModeLine "800x512d16" 54.375 800 800 840 848 512 512 514 515 HSkew 5 DoubleScan
+Hsync +Vsync 

ModeLine "800x512d08" 54.375 800 800 840 848 512 512 514 515 HSkew 1 DoubleScan
+Hsync +Vsync 

EndSection 

I will have to reboot to windows to find the inf file.
Comment 9 Jason 2003-05-25 17:31:06 EDT
Created attachment 91957 [details]
inf for sgi 1600sw monitor
Comment 10 Jason 2003-05-25 17:32:06 EDT
Created attachment 91958 [details]
original inf file
Comment 11 Bill Nottingham 2004-01-29 01:10:08 EST
Added, will be in 1.105-1.

Note You need to log in before you can comment on or make changes to this bug.