Bug 887115 - After subscribing one subscription, there was no redhat.repo generated.
Summary: After subscribing one subscription, there was no redhat.repo generated.
Keywords:
Status: CLOSED DUPLICATE of bug 886992
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: IDM QE LIST
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-14 04:00 UTC by Hui Wang
Modified: 2012-12-14 20:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-14 20:24:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Hui Wang 2012-12-14 04:00:13 UTC
Description of problem:
There was no redhat.repo generated in /etc/yum.repos.d/ after subscribing.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Edit the /etc/rhsm/rhsm.conf 
hostname = subscription.rhn.stage.redhat.com
2. Register Os to stage candlepin
# subscription-manager  register
Username: stage_test_12
Password: 
The system has been registered with id: e5bf03af-9849-4cfe-9824-9fdc51d47124 
3. List available subscriptions
# subscription-manager  list --available
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name:    	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to 4 guests)
SKU:                  	RH0103708
Pool Id:              	8a99f9843a7a3a9d013a8c036c383788
Quantity:             	35
Service Level:        	Premium
Service Type:         	L1-L3
Multi-Entitlement:    	No
Ends:                 	12/30/2012
System Type:          	Physical

4. Auto subscribe available subscription

# subscription-manager  subscribe --auto
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed
# subscription-manager  list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+

Subscription Name:    	Red Hat Enterprise Linux Server, Premium (8 sockets) (Up to 4 guests)
Provides:             	Red Hat Beta
                      	Red Hat Enterprise Linux Server
SKU:                  	RH0103708
Contract:             	10011052
Account:              	5206751
Serial Number:        	2998838066057705410
Active:               	True
Quantity Used:        	1
Service Level:        	Premium
Service Type:         	L1-L3
Starts:               	12/31/2011
Ends:                 	12/30/2012

5. yum repolist
Loaded plugins: product-id, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
repolist: 0
^^^^^^^^^no any repo list

6.Check the redhat.repo file
# cd /etc/yum.repos.d/
# ls
rhel-source.repo
[root@hp-dc5850-03 yum.repos.d]

[root@hp-dc5850-03 yum.repos.d]# ls
rhel-source.repo
^^^^^^^^^There was no the redhat.repo
  
Actual results:
As above

Expected results:
Should generate redhat.repo after subscribing some subscriptions and there will list some repoid when running "yum repolist"

Additional info:

Comment 2 Hui Wang 2012-12-14 04:03:27 UTC
version:
subscription-manager-1.1.14-1.el6.x86_64
python-rhsm-1.1.7-1.el6.x86_64

Comment 3 Adrian Likins 2012-12-14 20:24:40 UTC

*** This bug has been marked as a duplicate of bug 886992 ***


Note You need to log in before you can comment on or make changes to this bug.