Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 887140 - New .mount files can't be enabled to boot on startup
Summary: New .mount files can't be enabled to boot on startup
Keywords:
Status: CLOSED DUPLICATE of bug 955379
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-14 06:33 UTC by Vasiliy Glazov
Modified: 2013-05-06 17:49 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-06 17:49:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Vasiliy Glazov 2012-12-14 06:33:32 UTC
Description of problem:
New .mount files can't be enabled to boot on startup via systemctl tool. It can be done only with manual ln -s linking to target directory.

Version-Release number of selected component (if applicable):
systemd-44-21.fc17.x86_64
kernel-3.6.9-2.fc17.x86_64
All packages up to date.

How reproducible:
Always

Steps to Reproduce:
1. Create new .mount file
2. Link it to /etc/systemd/system/
3. systemctl enable mnt-disk_c.mount
  
Actual results:
Failed to issue method call: No such file or directory

Expected results:
No output

Additional info:
Other commans work good: status, start...
It can be mounted manually systemctl start mnt-disk_c.mount

The same bug in F18.

Comment 1 Arthur 2012-12-14 06:36:26 UTC
+1 so am I :(

Comment 2 Michal Schmidt 2012-12-14 15:42:44 UTC
(In reply to comment #0)
> Steps to Reproduce:
> 1. Create new .mount file
> 2. Link it to /etc/systemd/system/

Does it work if the unit file is stored directly in the /etc/systemd/system/ directory, rather than merely symlinked there?

Comment 3 Vasiliy Glazov 2012-12-14 17:36:25 UTC
Yes, it work if the unit file is stored directly in the /etc/systemd/system/ directory.

Comment 4 Lennart Poettering 2013-05-06 17:49:47 UTC

*** This bug has been marked as a duplicate of bug 955379 ***


Note You need to log in before you can comment on or make changes to this bug.