Bug 887228 - deadlock in lvmetad
Summary: deadlock in lvmetad
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Petr Rockai
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 895654
TreeView+ depends on / blocked
 
Reported: 2012-12-14 11:35 UTC by Marian Csontos
Modified: 2013-02-21 08:15 UTC (History)
11 users (show)

Fixed In Version: lvm2-2.02.98-6.el6
Doc Type: Bug Fix
Doc Text:
A nested mutex lock could result in a deadlock in lvmetad, leading to a lockup (hang) in LVM commands trying to talk to lvmetad. The nested lock has been removed, avoiding the possibility of a deadlock.
Clone Of:
Environment:
Last Closed: 2013-02-21 08:15:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
gdb output (4.51 KB, application/x-gzip)
2012-12-14 11:35 UTC, Marian Csontos
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0501 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2013-02-20 21:30:45 UTC

Description Marian Csontos 2012-12-14 11:35:51 UTC
Created attachment 663522 [details]
gdb output

Description of problem:
deadlock in lvmetad

Version-Release number of selected component (if applicable):
lvm2-2.02.98-5.15.el6_4

How reproducible:
???

Steps to Reproduce:
1. ???
  
Actual results:
deadlock

Expected results:
pass

Additional info:

There were one `lvs -a -o +devices` and few `/sbin/lvm pvscan --cache --activate ay --major %d --minor %d` commands spawned by udev.

Comment 3 Petr Rockai 2012-12-16 23:54:40 UTC
I have (hopefully) fixed the bug in fae1a611d2f907aa23c237b9f84df5089d30f728. A related fix is in 5294a6f77a900493b3e81eb70c1698ec3c4814b8. I would suggest both to be included in 6.4. No special QA treatment is required (the bug is exposed by existing testcases, it just triggers rarely).

Comment 4 Peter Rajnoha 2012-12-17 16:10:17 UTC
The latest scratch build that includes those two patches:
https://brewweb.devel.redhat.com/taskinfo?taskID=5198439

Comment 6 RHEL Product and Program Management 2012-12-17 17:56:42 UTC
Quality Engineering Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 10 errata-xmlrpc 2013-02-21 08:15:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0501.html


Note You need to log in before you can comment on or make changes to this bug.