Bug 88723 - new glibc corrupts time-of-day logging
Summary: new glibc corrupts time-of-day logging
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-12 16:43 UTC by Robert M. Riches Jr.
Modified: 2016-11-24 14:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 18:30:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert M. Riches Jr. 2003-04-12 16:43:38 UTC
Description of problem:
The new glibc (or something else made available to up2date between
4/5 and 4/12) corrupts time-of-day logging during boot.  It appears
timezone information is corrupted from when sshd starts and some
point later in booting.

Version-Release number of selected component (if applicable):
glibc-2.3.2-4.80.6

How reproducible:
100% of the two times I rebooted since updating

Steps to Reproduce:
0. Have system clock set to use UTC.
1. run up2date to get the latest RPMs.
2. reboot.
3. Look at times in /var/log/boot.log.  They will jump
   forward several hours just after sshd starts.  Then,
   they will jump back to where they are supposed to be
   later in the boot sequence.
    
Actual results:
Times logged in /var/log/boot.log and /var/log/messages
jump ahead several hours just after sshd starts and jump
back later in the sequence.

Expected results:
Times logged should be reasonably monotonic.

Additional info:

Comment 1 Ulrich Drepper 2003-04-22 08:36:22 UTC
I never saw anything like this and apparently nobody else did.  Can you
reproduce this on a freshly installed system without local modifications?  And
especially with RHL9?

Comment 2 Ulrich Drepper 2003-10-03 18:30:16 UTC
No reply in more than 5 months.  I'm closing this as WORKSFORME.


Note You need to log in before you can comment on or make changes to this bug.