Bug 8873 - RFE: Mouse configuration using keyboard is confusing
Summary: RFE: Mouse configuration using keyboard is confusing
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-25 22:10 UTC by Tim Waugh
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-27 16:54:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2000-01-25 22:10:56 UTC
At the mouse configuration screen if you press the down arrow on the
keyboard, rather than moving the highlighted selection down one line it
starts at the top of the list of mouse choices.

Comment 1 Jay Turner 2000-02-04 16:27:59 UTC
GUI or TUI?

Comment 2 Tim Waugh 2000-02-04 16:29:59 UTC
GUI.

Comment 3 Jay Turner 2000-02-23 21:35:59 UTC
Added to list of feature requests.

Comment 4 Michael Fulbright 2000-09-15 22:07:52 UTC
Please verify this against 7.0 Brock.

Comment 5 Brock Organ 2000-11-01 21:19:55 UTC
reassigning these to dale@redhat.com for further review ...

Comment 6 Dale Lovelace 2000-11-03 20:32:17 UTC
  I have verified this behaviour. On my test machine I have a "3 Button Mouse
(PS/2)' which is correctly detected. After the auto-detection if I press the
down arrow from the keyboard, instead of moving to the next item in the list,
which in this case would be "3 Button Mouse (USB)", the cursor instead moves to
the first item in the list "ALPS Glidepoint (PS/2)".

  I will change the severity of this to "Enhancement" and assign it to msf.

Comment 7 Brent Fox 2000-12-20 04:40:11 UTC
I'll agree that this behavior is annoying.  However, this is due largely to
GtkCTree's unintelligent focus behavior.  This is probably fixable, but I think
that development time could be better spent on bigger issues.  We plan on
porting anaconda to GTK 2.0 when it is released.  I think that GTK 2.0 will
replace GtkCTree with GtkTreeModel, which will hopefully resolve this issue.
I'm deferring this bug until that time.

Comment 8 Brent Fox 2001-09-26 18:51:13 UTC
Perhaps GTK2 will get us this behavior?

Comment 9 Brent Fox 2001-10-23 04:36:56 UTC
Turns out that GTK2 will not provide this behavior.  I think this is too minor
to worry about fixing.


Note You need to log in before you can comment on or make changes to this bug.