Bug 887363 - cloud-init 0.7.1 change prevents creation of ec2-user
cloud-init 0.7.1 change prevents creation of ec2-user
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cloud-init (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Garrett Holmstrom
Fedora Extras Quality Assurance
AcceptedBlocker
: Reopened
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-12-14 14:53 EST by Matthew Miller
Modified: 2012-12-20 16:20 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 16:20:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2012-12-14 14:53:16 EST
There's a config file change required for cloud-init in order for it at all useful. Specifically, the config file now needs to define default_user, like so:


  default_user:
    name: ec2-user
    lock_passwd: true
    gecos: EC2 user
    groups: [wheel, adm]
    sudo: ["ALL=(ALL) NOPASSWD:ALL"]
    shell: /bin/bash


Veersion 0.7.1-2 has the right config and I've confirmed that it works.

http://koji.fedoraproject.org/koji/buildinfo?buildID=372996

Sorry, QA/rel-eng team. Should have caught this sooner. We kinda need it in the release itself so we can make the EC2 images.

(Alternative I guess would be to roll back to 0.7.0 packages, but there's other bugfixes here.)
Comment 1 Fedora Update System 2012-12-14 15:11:33 EST
cloud-init-0.7.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/cloud-init-0.7.1-2.fc18
Comment 2 Fedora Update System 2012-12-14 18:21:25 EST
Package cloud-init-0.7.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cloud-init-0.7.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20389/cloud-init-0.7.1-2.fc18
then log in and leave karma (feedback).
Comment 3 Tim Flink 2012-12-17 05:10:39 EST
As stated, this violates the following F18 final release criterion [1]:

The release must boot successfully as Xen DomU with releases providing a functional, supported Xen Dom0 and widely used cloud providers utilizing Xen. This does not include any issues limited to the release functioning as Xen Dom0 

[1] http://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria
Comment 4 Adam Williamson 2012-12-17 13:36:47 EST
Discussed at 2012-12-17 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-17/f18final-blocker-review-5.2012-12-17-16.40.log.txt . Accepted as a blocker per criterion cited in comment #3.
Comment 5 Fedora Update System 2012-12-20 00:31:39 EST
cloud-init-0.7.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Kamil Páral 2012-12-20 07:52:55 EST
Matthew, can you please verify the issue is really fixed now? Thanks!
Comment 7 Adam Williamson 2012-12-20 16:20:23 EST
The  karma on the update that confirms the fix.

" mattdm - 2012-12-14 20:15:35
Examined change (minimal) and tested actual build. Looks good. "

plus two others.

Note You need to log in before you can comment on or make changes to this bug.