Bug 88740 - HUGE fonts for some applications on Redhat 9
HUGE fonts for some applications on Redhat 9
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: fontconfig (Show other bugs)
9
i386 Linux
high Severity high
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-12 16:13 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-13 13:54:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-04-12 16:13:37 EDT
Description of problem:

Some fonts in some applications look HUGE.



        Just installed RH 9 on my laptop. For certain applications, the fon
ts are HUGE. For instance, I just tried to install OpenOffice 1.0.3 (after the
fonts for the default installation looked HUGE), and the dialog box text is as
large as my screen. In another application (maxima using imaxima), the same
thing happens. Somehow it seems that the default font size is set to something
like 90 pts !!

        How do I fix this ?

Version-Release number of selected component (if applicable):

This seems to be a problem across programs. 

How reproducible:

On affected applications, every time.

Steps to Reproduce:
1.Just run the affected application.
2.
3.
    
Actual results:

HUGE fonts.

Expected results:

Something readable.

Additional info:

See the following bug (it might be related) :

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=88691
Comment 1 Owen Taylor 2003-04-13 10:47:32 EDT
Peculiar, since OpenOffice.org font drawing goes through an entirely
different path than the all the other fonts on your system... it
doesn't use fontconfig.

I know nothing about maxima/imaxima (I assume it's some 3rd party
application) but it's odd that it would have the same problem.

You might want to check what the server thinks your display resolution
is:

 xdpyinfo | grep resolution

That should be between, say, 75 and 125 dpi. If the resolution is far
from that, then it means that something went wrong with the server's
attempt to determine the size of your monitor. You can work around this
by setting DisplaySize  in your XF86Config (see the XF86Config man page.)

(Note that we don't use this resolution for computing the size of most
fonts on the system, but it's possible that some programs like OOo
might do that.)
Comment 2 Need Real Name 2003-04-13 13:54:21 EDT
Thanks !!

That fixed it, and even resolved another bug that I had submitted (not being
able to open postscript documents because of a backing pixmap problem).

There was a line in my /etc/X11/XF86Config :

DisplaySize 11 9

That somehow translated into a resolution of something like 2000+/1500+.

I removed the offending line and now the resolution is down to 75/75.

It was interesting to see how some (not all) fonts were affected by the X server
misconfiguration.
Comment 3 Owen Taylor 2003-04-14 12:58:48 EDT
Any idea of how the DisplaySize line got there? If the installer or
redhat-config-xfree86 wrote it, that's something we need to look at.

Note You need to log in before you can comment on or make changes to this bug.