Bug 887431 - [pt_BR] pofilter variables test is failing on a missing %s in the msgstr
[pt_BR] pofilter variables test is failing on a missing %s in the msgstr
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-12-15 00:25 EST by John Sefler
Modified: 2013-02-21 04:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:04:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-15 00:25:22 EST
Description of problem:

# (pofilter) variables: Do not translate: %s
msgid "%s subscriptions removed from this system."
msgstr "% subscrições removidas deste sistema"
        ^
        THIS SHOULD BE %s

This mistake will fail to produce a translation at runtime.  For example:

[root@jsefler-6 ~]# LANG=pt_BR.UTF-8 subscription-manager remove --all
2 subscriptions removed from this system.

Expected Results:
2 subscrições removidas deste sistema



Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.15-1.el6.x86_64
Comment 3 John Sefler 2012-12-21 18:27:28 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64

[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po

[root@jsefler-6 ~]# pofilter -t printf /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%

VERIFIED: pofilter printf test is now passing for LANG=pt_BR

[root@jsefler-6 ~]# pofilter -t variables /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%

VERIFIED: pofilter variables test is now passing for LANG=pt_BR

[root@jsefler-6 ~]# grep -A1 "%s subscriptions removed from this system." /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
msgid "%s subscriptions removed from this system."
msgstr "%s subscrições removidas deste sistema"

VERIFIED
Comment 6 errata-xmlrpc 2013-02-21 04:04:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.