Bug 887464 - [abrt] claws-mail-3.9.0-1.fc18: clamav_create_widget_func: Process /usr/bin/claws-mail was killed by signal 11 (SIGSEGV)
Summary: [abrt] claws-mail-3.9.0-1.fc18: clamav_create_widget_func: Process /usr/bin/c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: claws-mail-plugins
Version: 18
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL: http://www.thewildbeast.co.uk/claws-m...
Whiteboard: abrt_hash:a68e41140bdfb99af72ce80c833...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-15 14:11 UTC by Frank Murphy
Modified: 2013-07-08 18:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-08 18:42:42 UTC


Attachments (Terms of Use)
one basic way to fix it (524 bytes, patch)
2012-12-15 21:47 UTC, Michael Schwendt
no flags Details | Diff
regenerated the missing backtrace (87.66 KB, text/plain)
2012-12-15 21:55 UTC, Michael Schwendt
no flags Details

Description Frank Murphy 2012-12-15 14:11:16 UTC
Description of problem:
Had unchecked clamd plugin, due to problems with ping clamd. https://lists.fedoraproject.org/pipermail/test/2012-December/112542.html
Now hen I go to re-check scan all messages "Configuratuion - Prefrences - plugins - clamd" it crashes

Version-Release number of selected component:
claws-mail-3.9.0-1.fc18

Additional info:
backtrace_rating: 4
cmdline:        claws-mail
crash_function: clamav_create_widget_func
executable:     /usr/bin/claws-mail
kernel:         3.6.10-4.fc18.x86_64
remote_result:  838727
uid:            1005
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 clamav_create_widget_func at clamav_plugin_gtk.c:430
 #1 prefswindow_build_page at prefswindow.c:304
 #3 prefswindow_row_selected at prefswindow.c:724
 #5 _gtk_tree_selection_row_is_selectable at gtktreeselection.c:1273
 #6 _gtk_tree_selection_internal_select_node at gtktreeselection.c:1330
 #8 gtk_tree_view_real_set_cursor at gtktreeview.c:12595
 #9 gtk_tree_view_button_press at gtktreeview.c:2797
 #10 _gtk_marshal_BOOLEAN__BOXED at gtkmarshalers.c:86
 #15 gtk_widget_event_internal at gtkwidget.c:5017
 #16 gtk_widget_event at gtkwidget.c:4814

Comment 1 Michael Schwendt 2012-12-15 15:01:15 UTC
Please try to resubmit this bug report in ABRT. So far, there are no attachments. No stacktrace.

Comment 2 Frank Murphy 2012-12-15 15:07:17 UTC
Re-Posting

backtrace_rating: 4
Package: claws-mail-3.9.0-1.fc18
OS Release: Fedora release 18 (Spherical Cow)

Comment 3 Michael Schwendt 2012-12-15 17:27:21 UTC
There's still no backtrace, and the line numbers in the truncated one are useless. You could still cut'n'paste the backtrace manually from within ABRT. Or generate it manually with gdb after using debuginfo-install, of course.

From a tester perspective, it has not been possible to reproduce a crash of the plugin's preferences dialog, no matter how often I tried to open/close it with clamd running or inactive.

Comment 4 Frank Murphy 2012-12-15 17:45:35 UTC
Unfortunately I can't at the moment.
Clamav is completely uninstalled.
it may have been causing the problem


abrt had been cleared out due to wanting to just add a comment,
and bz was giving a http 502. and not much extra

So will close as nab for this.
Until can reproduce.

Claws-mail is  now working with no clamd plugin or otherwise.

Comment 5 Michael Schwendt 2012-12-15 21:46:54 UTC
It *is* a bug. Claws Mail must not crash in the plugin preferences. Not either if the plugin code doesn't manage to connect with clamd.

But if it's not reproducible [and mind you, the developer(s) have likely not had it crash either], and without a detailed stacktrace, somebody would need to proof-read the source code and come up with a theory what might make it crash.

That is what I've done after skimming over the source code. :-)

Comment 6 Michael Schwendt 2012-12-15 21:47:26 UTC
Created attachment 664151 [details]
one basic way to fix it

Comment 7 Michael Schwendt 2012-12-15 21:55:28 UTC
Created attachment 664152 [details]
regenerated the missing backtrace

Comment 8 Michael Schwendt 2012-12-16 09:18:45 UTC
Upstream has found an underlying [worse] problem in the code, which to fix will need more changes.

Comment 9 Michael Schwendt 2013-01-31 11:00:02 UTC
http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=2838#c4
|
| Changes related to this bug have been committed.
| Please check latest CVS and update the bug accordingly.

Comment 10 Michael Schwendt 2013-03-07 20:12:22 UTC
Fix is included since

 - claws-mail-3.9.0cvs75
 - clamd-3.5.5cvs2.tar.gz (for old extra plugins)


Note You need to log in before you can comment on or make changes to this bug.