Bug 88748 - Second monitor turns off with ATI Radeon and Xinerama
Second monitor turns off with ATI Radeon and Xinerama
Status: CLOSED DUPLICATE of bug 87854
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-12 21:03 EDT by Andrew Rechenberg
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes ATI Radeon second monitor turning off with xinerama (526 bytes, patch)
2003-04-12 21:06 EDT, Andrew Rechenberg
no flags Details | Diff

  None (edit)
Description Andrew Rechenberg 2003-04-12 21:03:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
The ATI Radeon dual head card is deteced and configured correctly upon upgrading
my workstation from Red Hat 8.0 to Red Hat 9.  However when I move my cursor to
the second monitor it shuts down.

According to the Shrike users list, this is caused by a typo in the
radeon_cursor.c file.  I patched the file as suggested on the mailing list and
rebuilt the RPMS and now my Xinerama configuration works.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat 9 on box with ATI Radeon 7000 (maybe others)
2. Configure Xinerama (or have redhat-config-xfree86 do it)
3. Move cursor onto second monitor and watch it turn off
    

Actual Results:  Monitor turns off

Expected Results:  Monitor should not turn off

Additional info:
Comment 1 Andrew Rechenberg 2003-04-12 21:06:40 EDT
Created attachment 91104 [details]
Fixes ATI Radeon second monitor turning off with xinerama

I added this patch as Patch136, and added '%patch136 -p0' as well to the
XFree86.spec file and then rebuilt the RPMS.
Comment 2 Mike A. Harris 2003-04-12 21:26:12 EDT
While this is allready reported in bugzilla, and the same patch present,
thanks nonetheless for your feedback and for attaching the patch as well.

*** This bug has been marked as a duplicate of 87544 ***
Comment 3 Mike A. Harris 2003-04-12 21:28:10 EDT
Argh, closed as dupe of wrong bug number.
Comment 4 Mike A. Harris 2003-04-12 21:30:26 EDT

*** This bug has been marked as a duplicate of 87854 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:52:39 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.