Bug 88750 - redhat-config-soundcard won't configure SB Live!
redhat-config-soundcard won't configure SB Live!
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-soundcard (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-12 21:48 EDT by Steven Brooks
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-20 16:18:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Brooks 2003-04-12 21:48:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
(This may or may not be related to Bug 75015.  I've entered it as a separate bug
because I don't have any USB device capable of sound input or output.)

When I run redhat-config-soundcard, it detects my card correctly as a SB Live!
EMU10k1.  But it says that the module is "disabled".  Nothing I can do via
redhat-config-soundcard will activate it.

I assume there is some kind of misdetection going on here, because SB Live! is
listed as being supported on hardware.redhat.com.  Although, technically, my
card is an SB Live! Value.

I manually edited /etc/modules.conf to load the emu10k1 driver, and it seems to
work fine.

I have a USB Scanner and USB Keyboard/Hub, but I do not have a USB audio device
or webcam.  (Which is why this may be different from Bug 75015.)

I notice that kudzu seems to have seen the device.  Here is a section from
/etc/sysconfig/hwconf; at least, I assume kudzu is what made this file:
----
class: OTHER
bus: PCI
detached: 0
driver: disabled
desc: "Creative Labs|SB Live! MIDI/Game Port"
vendorId: 1102
deviceId: 7002
subVendorId: 1102
subDeviceId: 0020
pciType: 1
----

Here is the entry from /proc/pci:
----
  Bus  0, device  15, function  0:
    Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 8).
      IRQ 5.
      Master Capable.  Latency=32.  Min Gnt=2.Max Lat=20.
      I/O at 0xb400 [0xb41f].
  Bus  0, device  15, function  1:
    Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 8).
      Master Capable.  Latency=32.
      I/O at 0xb000 [0xb007].
----

There are no other sound card entries in /proc/pci, so if my motherboard (an
Asus A7V266-E) has an on-board sound card, I must've disabled it when I got the
SB Live!.  (So this should not be the same as Bug 30677.)

Version-Release number of selected component (if applicable):
redhat-config-soundcard-1.0.4-2

How reproducible:
Always

Steps to Reproduce:
1.Install RedHat 8 or 9 on this system.
2.Go to redhat-config-soundcard.

    

Actual Results:  Module will be listed as disabled in redhat-config-soundcard. 
Sound will be disabled.

Expected Results:  Module is configured using the emu10k1 module.

Additional info:
Comment 1 Brent Fox 2003-04-14 15:41:45 EDT
Hmm, my SB Live! works just fine.  Here are the contents of my files:

From /proc/pci:

  Bus  2, device   8, function  0:
    Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 7).
      IRQ 9.
      Master Capable.  Latency=64.  Min Gnt=2.Max Lat=20.
      I/O at 0xec60 [0xec7f].
  Bus  2, device   8, function  1:
    Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 7).
      Master Capable.  Latency=64.
      I/O at 0xec58 [0xec5f].

From /etc/sysconfig/hwconf:

class: AUDIO
bus: PCI
detached: 0
driver: emu10k1
desc: "Creative Labs|SB Live! EMU10k1"
vendorId: 1102
deviceId: 0002
subVendorId: 1102
subDeviceId: 8022
pciType: 1

I don't know why your driver section says "disabled" and mine says "emu10k1". 
notting, any ideas why that would happen?
Comment 2 Bill Nottingham 2003-04-14 16:19:35 EDT
It's a kudzu probing issue interacting with the BIOS, already changed after the
release. Basically, the card doesn't have an interrupt assigned to it until
after the module is loaded. You might be able to twiddle your BIOS to fix this.
Comment 3 Steven Brooks 2003-04-14 16:58:44 EDT
Thanks, although I've already manually configured my soundcard, which seems to
have worked fine.
Comment 4 Brent Fox 2003-05-20 16:18:40 EDT
Ok, I'll resolve this as Rawhide since Bill says that a new kudzu fixes the problem.

Note You need to log in before you can comment on or make changes to this bug.