Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 887526 - anaconda manual partitioning 'reformat' 1 of 2 biosboot partition results in two entries shown in the 'New Fedora...' tree instead of only one
Summary: anaconda manual partitioning 'reformat' 1 of 2 biosboot partition results in ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-16 00:42 UTC by Reartes Guillermo
Modified: 2014-10-20 23:02 UTC (History)
5 users (show)

Fixed In Version: anaconda-21.48.10-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-20 23:02:03 UTC
Type: Bug


Attachments (Terms of Use)
screenshot showing the dupplicate biosboot entries (102.22 KB, image/png)
2012-12-16 00:42 UTC, Reartes Guillermo
no flags Details
anaconda.log (14.74 KB, text/plain)
2012-12-18 23:21 UTC, Reartes Guillermo
no flags Details
storage.log (300.85 KB, text/plain)
2012-12-18 23:21 UTC, Reartes Guillermo
no flags Details
program.log (47.09 KB, text/plain)
2012-12-18 23:22 UTC, Reartes Guillermo
no flags Details
[18.37.11] screenshot showing duplicate BIOS Boot entries (74.10 KB, image/png)
2013-01-21 04:07 UTC, Steve Tyler
no flags Details
[18.37.11] anaconda.log (14.34 KB, text/plain)
2013-01-21 04:12 UTC, Steve Tyler
no flags Details
[18.37.11] program.log (42.83 KB, text/plain)
2013-01-21 04:14 UTC, Steve Tyler
no flags Details
[18.37.11] storage.log (103.69 KB, text/plain)
2013-01-21 04:15 UTC, Steve Tyler
no flags Details

Description Reartes Guillermo 2012-12-16 00:42:55 UTC
Created attachment 664200 [details]
screenshot showing the dupplicate biosboot entries

Description of problem:

This Guest is a replica of my main F17 system (with smaller disk sizes).

So, there are two biosboot partitions (vda1, vdb1).
But it is enough for anaconda to just install the bootloader into vda1.
I normally setup vdb1 manually later.

When i select the desired biosboot partition and mark it as 'reformat', it shows up twice in the 'New Fedora...' tree. 

Since there are two biosboot partitions (vda1 and vdb1) and i only intend
to reformat vda1, it might cause confusion. 

Version-Release number of selected component (if applicable):
anaconda 18.37.2

How reproducible:
always

Steps to Reproduce:

0. Boot anaconda with 'gpt' boot parameter. I don't know if it is requiered, since the disks are already partitioned, but just in case.

1. Select my favorite anaconda settings (spanish, buenos aires, kde)

2. Enter STORAGE: INSTALLATION DESTINATION and select only vda and vdb.

3. Perform MANUAL PARTITIONING (Do not chage the scheme).

4. Expand the 'unknown' tree and select vda1 (biosboot). Expand the 'customize' 
tree and check 'reformat' and 'apply changes'. 

5. Expand the 'New Fedora 18...' tree and there will be two 'biosboot' entries 
instead of only one.

6. It is possible to perform the installation correctly. It looks like there are
two duplicated entries. 

  
Actual results:
it looks like a cosmetic issue. 

Expected results:
no duplicated entries in the 'New Fedora...' tree.

Additional info:

Comment 1 Brian Lane 2012-12-18 23:01:33 UTC
Please attach logs from /tmp/*log as individual plain/text files.

Comment 2 Reartes Guillermo 2012-12-18 23:21:28 UTC
Created attachment 665822 [details]
anaconda.log

Comment 3 Reartes Guillermo 2012-12-18 23:21:57 UTC
Created attachment 665823 [details]
storage.log

Comment 4 Reartes Guillermo 2012-12-18 23:22:31 UTC
Created attachment 665824 [details]
program.log

Comment 5 Steve Tyler 2013-01-21 04:07:55 UTC
Created attachment 684034 [details]
[18.37.11] screenshot showing duplicate BIOS Boot entries

Reproduced with anaconda-18.37.11-1.fc18 using one disk and gparted.

Create an empty disk image:
$ qemu-img create f18-test-3.img 12G

Start the Live image:
$ qemu-kvm -m 2048 -hda f18-test-3.img -cdrom ~/xfr/fedora/F18/F18-Final/Final/Fedora-18-x86_64-Live-Desktop.iso -vga qxl -boot menu=on -usbdevice mouse

Install gparted and configure the disk with one bios_grub partition:
1. Create a gpt partition table.
2. Create an unformatted, 1 MiB partition.
3. Set the bios_grub flag on the partition.
4. Quit.

Start the installer.
Proceed to Manual Partitioning.
Click "+" to expand the Unknown installation.
Click "+" to expand Customize.
Click Reformat.
Click Apply Changes.
Click "+" to expand New Fedora 18 Installation.

BIOS Boot is displayed twice.
Both copies show sda1 as the name.

Comment 6 Steve Tyler 2013-01-21 04:12:37 UTC
Created attachment 684035 [details]
[18.37.11] anaconda.log

Comment 7 Steve Tyler 2013-01-21 04:14:48 UTC
Created attachment 684039 [details]
[18.37.11] program.log

Comment 8 Steve Tyler 2013-01-21 04:15:27 UTC
Created attachment 684040 [details]
[18.37.11] storage.log

Comment 9 Fedora Update System 2014-10-15 13:07:54 UTC
anaconda-21.48.10-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/anaconda-21.48.10-1.fc21

Comment 10 Fedora Update System 2014-10-16 17:18:39 UTC
Package anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.10-1.fc21 pykickstart-1.99.63-2.fc21 python-blivet-0.61.5-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12944/pykickstart-1.99.63-2.fc21,python-blivet-0.61.5-1.fc21,anaconda-21.48.10-1.fc21
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2014-10-20 23:02:03 UTC
anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.