Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 887537 - Multilib version problems found when installing virt-manager
Summary: Multilib version problems found when installing virt-manager
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cyrus-sasl
Version: 18
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Petr Lautrbach
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-16 04:50 UTC by bob
Modified: 2013-01-15 16:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-15 16:24:15 UTC
Type: Bug


Attachments (Terms of Use)

Description bob 2012-12-16 04:50:21 UTC
Description of problem:

Yum produces multiilb version problems when installing virt-manager.

Version-Release number of selected component (if applicable):

F18 Beta

How reproducible:

always
Steps to Reproduce:
1. yum install virt-manager
2.
3.
  
Actual results:

Protected multilib versions: cyrus-sasl-lib-2.1.23-36.fc18.i686 != cyrus-sasl-lib-2.1.25-2.fc18.x86_64


Expected results:

Clean install.

Additional info:

yum install produces the following error.  yum clean all doesn't change anything.

# yum install virt-manager 
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package virt-manager.noarch 0:0.9.4-3.fc18 will be installed
--> Processing Dependency: virt-manager-common = 0.9.4-3.fc18 for package: virt-manager-0.9.4-3.fc18.noarch
--> Processing Dependency: vte >= 0.12.2 for package: virt-manager-0.9.4-3.fc18.noarch
--> Processing Dependency: python-virtinst >= 0.600.3 for package: virt-manager-0.9.4-3.fc18.noarch
--> Processing Dependency: libvirt-python >= 0.7.0 for package: virt-manager-0.9.4-3.fc18.noarch
--> Processing Dependency: gtk-vnc-python >= 0.3.8 for package: virt-manager-0.9.4-3.fc18.noarch
--> Processing Dependency: gnome-python2-gconf >= 1.99.11-7 for package: virt-manager-0.9.4-3.fc18.noarch
--> Processing Dependency: spice-gtk-python for package: virt-manager-0.9.4-3.fc18.noarch
--> Processing Dependency: scrollkeeper for package: virt-manager-0.9.4-3.fc18.noarch
--> Running transaction check
---> Package gnome-python2-gconf.x86_64 0:2.28.1-9.fc18 will be installed
---> Package gtk-vnc-python.x86_64 0:0.5.1-5.fc18 will be installed
--> Processing Dependency: gtk-vnc = 0.5.1 for package: gtk-vnc-python-0.5.1-5.fc18.x86_64
--> Processing Dependency: libgvnc-1.0.so.0()(64bit) for package: gtk-vnc-python-0.5.1-5.fc18.x86_64
--> Processing Dependency: libgtk-vnc-1.0.so.0()(64bit) for package: gtk-vnc-python-0.5.1-5.fc18.x86_64
---> Package libvirt-python.x86_64 0:0.10.2.2-1.fc18 will be installed
--> Processing Dependency: libvirt-client = 0.10.2.2-1.fc18 for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_PRIVATE_0.10.2.2)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.9.9)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.9.8)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.9.7)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.9.5)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.9.4)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.9.3)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.9.2)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.9.13)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.9.11)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.9.10)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.9.0)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.8.8)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.8.6)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.8.5)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.8.2)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.8.1)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.8.0)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.7.7)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.7.5)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.7.3)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.7.2)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.7.1)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.7.0)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.6.4)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.6.3)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.6.1)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.6.0)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.5.0)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.4.5)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.4.2)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.4.1)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.4.0)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.3.3)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.3.2)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.3.0)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.2.3)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.2.1)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.2.0)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.10.2)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.10.0)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.1.9)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.1.5)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.1.4)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.1.1)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.1.0)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.0.5)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0(LIBVIRT_0.0.3)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt-qemu.so.0(LIBVIRT_QEMU_0.9.4)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt-qemu.so.0(LIBVIRT_QEMU_0.8.3)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt-qemu.so.0(LIBVIRT_QEMU_0.10.0)(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libwsman_curl_client_transport.so.1()(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libwsman_client.so.1()(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libwsman.so.1()(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt.so.0()(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: libvirt-qemu.so.0()(64bit) for package: libvirt-python-0.10.2.2-1.fc18.x86_64
---> Package python-virtinst.noarch 0:0.600.3-2.fc18 will be installed
---> Package rarian-compat.x86_64 0:0.8.1-8.fc18 will be installed
--> Processing Dependency: rarian = 0.8.1-8.fc18 for package: rarian-compat-0.8.1-8.fc18.x86_64
--> Processing Dependency: rarian for package: rarian-compat-0.8.1-8.fc18.x86_64
--> Processing Dependency: librarian.so.0()(64bit) for package: rarian-compat-0.8.1-8.fc18.x86_64
---> Package spice-gtk-python.x86_64 0:0.14-1.fc18 will be installed
--> Processing Dependency: spice-gtk(x86-64) = 0.14-1.fc18 for package: spice-gtk-python-0.14-1.fc18.x86_64
--> Processing Dependency: libspice-client-gtk-2.0.so.4(SPICEGTK_1)(64bit) for package: spice-gtk-python-0.14-1.fc18.x86_64
--> Processing Dependency: libspice-client-glib-2.0.so.8(SPICEGTK_1)(64bit) for package: spice-gtk-python-0.14-1.fc18.x86_64
--> Processing Dependency: libusbredirparser.so.1()(64bit) for package: spice-gtk-python-0.14-1.fc18.x86_64
--> Processing Dependency: libusbredirhost.so.1()(64bit) for package: spice-gtk-python-0.14-1.fc18.x86_64
--> Processing Dependency: libspice-client-gtk-2.0.so.4()(64bit) for package: spice-gtk-python-0.14-1.fc18.x86_64
--> Processing Dependency: libspice-client-glib-2.0.so.8()(64bit) for package: spice-gtk-python-0.14-1.fc18.x86_64
--> Processing Dependency: libcelt051.so.0()(64bit) for package: spice-gtk-python-0.14-1.fc18.x86_64
--> Processing Dependency: libcacard.so.0()(64bit) for package: spice-gtk-python-0.14-1.fc18.x86_64
---> Package virt-manager-common.noarch 0:0.9.4-3.fc18 will be installed
---> Package vte.x86_64 0:0.28.2-7.fc18 will be installed
--> Running transaction check
---> Package celt051.x86_64 0:0.5.1.3-5.fc18 will be installed
---> Package gtk-vnc.x86_64 0:0.5.1-5.fc18 will be installed
---> Package gvnc.x86_64 0:0.5.1-5.fc18 will be installed
---> Package libcacard.x86_64 0:0.1.2-3.fc18 will be installed
---> Package libvirt-client.x86_64 0:0.10.2.2-1.fc18 will be installed
--> Processing Dependency: gnutls-utils for package: libvirt-client-0.10.2.2-1.fc18.x86_64
--> Processing Dependency: cyrus-sasl-md5 for package: libvirt-client-0.10.2.2-1.fc18.x86_64
---> Package libwsman1.x86_64 0:2.3.6-1.fc18 will be installed
---> Package rarian.x86_64 0:0.8.1-8.fc18 will be installed
---> Package spice-glib.x86_64 0:0.14-1.fc18 will be installed
---> Package spice-gtk.x86_64 0:0.14-1.fc18 will be installed
---> Package usbredir.x86_64 0:0.5.2-1.fc18 will be installed
--> Running transaction check
---> Package cyrus-sasl-md5.x86_64 0:2.1.23-36.fc18 will be installed
--> Processing Dependency: cyrus-sasl-lib = 2.1.23-36.fc18 for package: cyrus-sasl-md5-2.1.23-36.fc18.x86_64
---> Package gnutls-utils.x86_64 0:2.12.21-1.fc18 will be installed
--> Running transaction check
---> Package cyrus-sasl-lib.i686 0:2.1.23-36.fc18 will be installed
--> Processing Dependency: libresolv.so.2 for package: cyrus-sasl-lib-2.1.23-36.fc18.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: cyrus-sasl-lib-2.1.23-36.fc18.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: cyrus-sasl-lib-2.1.23-36.fc18.i686
--> Processing Dependency: libdl.so.2 for package: cyrus-sasl-lib-2.1.23-36.fc18.i686
--> Processing Dependency: libdb-5.3.so for package: cyrus-sasl-lib-2.1.23-36.fc18.i686
--> Processing Dependency: libcrypt.so.1 for package: cyrus-sasl-lib-2.1.23-36.fc18.i686
--> Processing Dependency: libc.so.6(GLIBC_2.15) for package: cyrus-sasl-lib-2.1.23-36.fc18.i686
--> Running transaction check
---> Package glibc.i686 0:2.16-28.fc18 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.16-28.fc18.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.16-28.fc18.i686
---> Package libdb.i686 0:5.3.21-3.fc18 will be installed
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.14-5.fc18 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for cyrus-sasl-lib which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of cyrus-sasl-lib of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude cyrus-sasl-lib.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of cyrus-sasl-lib installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of cyrus-sasl-lib installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: cyrus-sasl-lib-2.1.23-36.fc18.i686 != cyrus-sasl-lib-2.1.25-2.fc18.x86_64

Comment 1 Cole Robinson 2012-12-16 15:53:38 UTC
Reproduced with

sudo yum install cyrus-sasl-lib.i686

so reassigning

Comment 2 Petr Lautrbach 2012-12-20 15:33:32 UTC
I've unpushed cyrus-sasl-2.1.25-2.fc18 from updates and updates-testing due #886140  so this issue should not happen anymore. If you have got cyrus-sasl-2.1.25-2.fc18 installed from updates-testing, please downgrade cyrus-sasl-* packages to 2.1.23-36.fc18 using 'yum downgrade cyrus-sasl\*'


Note You need to log in before you can comment on or make changes to this bug.