Bug 88754 - libpq++.so.4/libpq++.h are missing cannot compile programs
Summary: libpq++.so.4/libpq++.h are missing cannot compile programs
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-13 05:59 UTC by Robert Hyer
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-14 17:45:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Hyer 2003-04-13 05:59:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705; .NET CLR 1.1.4322)

Description of problem:
While compiling gnuworld. I do a ./configure to configure the program and to 
see if i'm missing anything.  When i do so it cannot find libpq++.so nor can 
it find libpq++.h.  I do a search using locate to find them.  They are no 
where to be found.  I tried to install older versions but since you changed 
the architexture i cannot install old ones since it looks for libs in other 
places. Anyways

Version-Release number of selected component (if applicable):
7.3.2

How reproducible:
Always

Steps to Reproduce:
1.install postgresql RPMS
2.compile gnuworld
3.missing libpq++.so libpq++.h
    

Additional info:

Comment 1 Andrew Overholt 2003-04-14 17:45:42 UTC
libpq++ has been spun out of the main PostgreSQL distribution and is now a
separate project that can be found at http://gborg.postgresql.org.  Work is not
currently focussed on creating RPMs for the interfaces that were spun-off, but
things should work fine with an installation of it from the tarball available at
GBorg.  You may wish to use libpqxx as your C++ interface as GBorg says it
"Supersedes [the] older libpq++ interface".


Note You need to log in before you can comment on or make changes to this bug.