Bug 88761 - Cannot copy files between remote mount points in Nautilus
Summary: Cannot copy files between remote mount points in Nautilus
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nautilus   
(Show other bugs)
Version: 9
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-13 13:55 UTC by Erik Reuter
Modified: 2015-01-08 00:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 13:28:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Erik Reuter 2003-04-13 13:55:08 UTC
If I drag files between 2 Nautilus windows, or selects copy and then paste where
both the source and destination directories are located on different mounted
filesystems (e.g. copy from nfs->vfat or vfat->vfat) Nautilus gives me a
"Generic Error" while copying. The same operation works in a term.

Comment 1 Alexander Larsson 2003-04-14 10:59:43 UTC
I wasn't able to reproduce this on nfs->vfat.


Comment 2 Alexander Larsson 2003-04-14 11:13:21 UTC
Any chance you could do an strace of the failure?
do something like "strace -t -o nautilus.log nautilus --no-desktop /nfs/dir1
/vfat/dir2", then wait a while after the windows pop up, do the copy, and when
you get the dialog ctrl-c nautilus and attach nautilus.log to this bug.


Comment 3 Erik Reuter 2003-04-14 22:08:06 UTC
Errrhhh.... Now I cant provoke the error anymore myself. It had been bugging me
since RedHat8 came out, I could have sworn that it did not work the other day.

I did run up2date and caught up with the latest stuff yesterday, cant remember
the specifics about what got updated.

Did you guys silently fix this, or am I going mad here?

Anyway, nice to have that working (at last for me, at least) so to have caused
you any inconvenience.


Comment 4 Alexander Larsson 2003-04-15 10:03:42 UTC
It might have involved symlinks. Can you reproduce it while copying some dir
that has a symlink in it?


Comment 5 Alexander Larsson 2004-10-04 13:28:35 UTC
No reply, seems fixed. Closing.


Note You need to log in before you can comment on or make changes to this bug.