Bug 88763 - gtk-doc uses cmp but does not depend on diffutils
Summary: gtk-doc uses cmp but does not depend on diffutils
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gtk-doc   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-13 17:03 UTC by Thomas Vander Stichele
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 20:44:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Vander Stichele 2003-04-13 17:03:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
while working in an autobuild system, I noticed gtk-doc needing cmp which wasn't
available since it is provided by diffutils but gtk-doc doesn't depend on it.

So please add diffutils to the Requires: of gtk-doc

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install a base system
2. install gtk-doc
3. run gtk-doc on a project
    

Actual Results:  error on missing cmp

Additional info:

Comment 1 Owen Taylor 2003-08-28 20:44:21 UTC
* Thu Aug 28 2003 Owen Taylor <otaylor@redhat.com> 1.1-3.0
- Move gtk-doc.pc file to %{_datadir}/pkgconfig (#98595)
- Require: /usr/bin/cmp (#88763, Thomas Vander Stichele)
- Added libxslt docbook-style-xsl to Require: and BuildPrereq
  (#99143, Ken MacFarlane)



Note You need to log in before you can comment on or make changes to this bug.