Bug 887711 - Cannot delete directory when special characters are used.
Cannot delete directory when special characters are used.
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Csaba Henk
:
: 887712 887713 887714 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-16 23:20 EST by Edwin Hernandez
Modified: 2013-02-20 01:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-20 01:32:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Edwin Hernandez 2012-12-16 23:20:32 EST
Description of problem:
I created a directory "-4oEo5VkALI" and cannot be deleted.

Version-Release number of selected component (if applicable):
3.3

How reproducible:
Easy

Steps to Reproduce:
1.Create a directory using os.mkdir or any other mechanism 
2. try to delete it via rm -rf "\-4oEo5VkALI" and will not be able to remove it.

  
Actual results:
Cannot delete directory

Expected results:
Directory deleted


Additional info:
Comment 1 Csaba Henk 2012-12-17 05:54:31 EST
*** Bug 887712 has been marked as a duplicate of this bug. ***
Comment 2 Csaba Henk 2012-12-17 06:40:04 EST
*** Bug 887714 has been marked as a duplicate of this bug. ***
Comment 3 Csaba Henk 2012-12-17 06:40:37 EST
*** Bug 887713 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Challen 2012-12-17 06:55:35 EST
I don't think this is a bug. Directories and files with - at the start of the name will cause problems in any POSIX file system. Try using a full or partial path:

rmdir ./-4oEo5VkALI

or the -- option:

rm -r -- -4oEo5VkALI
Comment 5 Amar Tumballi 2013-02-20 01:32:36 EST
comment #4 is precise, and please re-open if thats not the issue.

Note You need to log in before you can comment on or make changes to this bug.