Bug 88773 - xterm session management is disabled by default in XFree86 4.2.x
xterm session management is disabled by default in XFree86 4.2.x
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-13 18:48 EDT by Thomas E. Dickey
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-19 05:22:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86-4.2.1-xterm-session-management-resource.patch (1.02 KB, patch)
2003-04-17 22:38 EDT, Mike A. Harris
no flags Details | Diff

  None (edit)
Description Thomas E. Dickey 2003-04-13 18:48:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16 i686)

Description of problem:
I added (simple) session management a year ago for xterm.
Redhat's package patches the app-defaults file to disable it.
The session management code works; no one from Redhat reported
any bugs against it.

See the (uncommented) line for XTerm.JoinSession

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. logout from GNOME, saving settings
2.
3.
    

Actual Results:  GNOME asserts that xterm is not capable of saving its settings.

Expected Results:  xterm's geometry settings should be saved/restored.

Additional info:
Comment 1 Mike A. Harris 2003-04-14 16:20:33 EDT
Hmm, I don't recall making any changes like that to disable anything.  I'll
have to investigate why it's like this.  Perhaps someone else changed something
and I never noticed.

Just so you know, in general I ignore user's requests to modify xterm from
the stock default.  We have a few things that have been around for quite some
time which my life has been threatened should I remove them <grin>, but as
people report bugs caused by patches we apply, I have generally removed them
to eliminate Red Hat as the problem causer.  ;o)

If I could make xterm completely totally stock, and ship it like that, I would
do it in a millisecond.  That would save me quite a bit of hassles also.

I've got a secret plan to split xterm into a separate package so it can
be updated more easily independantly.  Perhaps I can sneakily remove some
more changes then too.  ;o)

I'll have a look at what you mention above and see what I can do.

Thanks Thomas.
Comment 2 Thomas E. Dickey 2003-04-14 17:06:11 EDT
hmm - I think I was up too late the night before.  It's a bug inredhat8 which I was thinking carried over to redhat9.  But now I
see it was a fix I made about a month before redhat8 - so it
"should" be correct in redhat9 if you're not patching.  (but
verify - I removed my temporary copies of rpm's that I used to
inspect ;-)
Comment 3 Mike A. Harris 2003-04-17 21:56:54 EDT
Here's a diff between our 4.2.1 and 4.3.0 with patched sources in both
cases.  I've looked at our Xterm resources patch and it doesn't appear
to be modifying this resource, but I'll check against stock sources in
a sec also.

[mharris@devel xterm-177]$ diff -u
/home/mharris/rpmbuild/BUILD/XFree86-4.2.1/xc/programs/xterm/XTerm.ad
/home/mharris/rpmbuild/BUILD/XFree86-4.3.0/xc/programs/xterm/XTerm.ad
--- /home/mharris/rpmbuild/BUILD/XFree86-4.2.1/xc/programs/xterm/XTerm.ad      
2003-04-14 17:19:07.000000000 -0400
+++ /home/mharris/rpmbuild/BUILD/XFree86-4.3.0/xc/programs/xterm/XTerm.ad      
2003-04-14 21:50:53.000000000 -0400
@@ -3,9 +3,11 @@
 !
 !
 !
-! $XFree86: xc/programs/xterm/XTerm.ad,v 3.21 2001/10/08 01:08:10 dickey Exp $
+! $XFree86: xc/programs/xterm/XTerm.ad,v 3.23 2002/08/12 00:36:32 dickey Exp $
 
-XTerm.JoinSession:False
+! This is nonsense: if the xterm has no session management capabilities,
+! it is useless, and if it does, it is harmful.
+!XTerm.JoinSession:False
 
 *SimpleMenu*BackingStore: NotUseful
 *SimpleMenu*menuLabel.font: -adobe-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-*
@@ -18,9 +20,10 @@
 *mainMenu.Label:  Main Options
 *mainMenu*securekbd*Label:  Secure Keyboard
 *mainMenu*allowsends*Label:  Allow SendEvents
+*mainMenu*redraw*Label:  Redraw Window
 *mainMenu*logging*Label:  Log to File
 *mainMenu*print*Label:  Print Window
-*mainMenu*redraw*Label:  Redraw Window
+*mainMenu*print-redir*Label:  Redirect to Printer
 *mainMenu*8-bit control*Label: 8-Bit Controls
 *mainMenu*backarrow key*Label: Backarrow Key (BS/DEL)
 *mainMenu*num-lock*Label: Alt/NumLock Modifiers
Comment 4 Mike A. Harris 2003-04-17 22:30:33 EDT
Here's a diff of stock unpatched 4.2.1 vs. 4.3.0 from tarballs:

[mharris@devel tmp]$ diff -u xc421/programs/xterm/XTerm.ad
xc430/programs/xterm/XTerm.ad
--- xc421/programs/xterm/XTerm.ad       2002-01-05 17:05:02.000000000 -0500
+++ xc430/programs/xterm/XTerm.ad       2002-09-29 20:39:05.000000000 -0400
@@ -3,9 +3,11 @@
 !
 !
 !
-! $XFree86: xc/programs/xterm/XTerm.ad,v 3.21 2001/10/08 01:08:10 dickey Exp $
+! $XFree86: xc/programs/xterm/XTerm.ad,v 3.23 2002/08/12 00:36:32 dickey Exp $
 
-XTerm.JoinSession:False
+! This is nonsense: if the xterm has no session management capabilities,
+! it is useless, and if it does, it is harmful.
+!XTerm.JoinSession:False
 
 *SimpleMenu*BackingStore: NotUseful
 *SimpleMenu*menuLabel.font: -adobe-helvetica-bold-r-normal--*-120-*-*-*-*-iso8859-*
@@ -18,9 +20,10 @@
 *mainMenu.Label:  Main Options
 *mainMenu*securekbd*Label:  Secure Keyboard
 *mainMenu*allowsends*Label:  Allow SendEvents
+*mainMenu*redraw*Label:  Redraw Window
 *mainMenu*logging*Label:  Log to File
 *mainMenu*print*Label:  Print Window
-*mainMenu*redraw*Label:  Redraw Window
+*mainMenu*print-redir*Label:  Redirect to Printer
 *mainMenu*8-bit control*Label: 8-Bit Controls
 *mainMenu*backarrow key*Label: Backarrow Key (BS/DEL)
 *mainMenu*num-lock*Label: Alt/NumLock Modifiers

So, if I read things correctly, the flaw is in stock 4.2.1 which was
fixed in 4.3.0 that you'd like patched in our 4.2.1 also.  I can make that
change if you like since we're going to be releasing 4.2.1 erratum for
both Red Hat Linux 7.3 and 8.0 real soon now.  I'll attach a proposed
patch, and if it looks ok to you and you'd like it applied, I'll apply
it to our next 4.2.1 builds.

Please let me know as soon as possible if this patch is ok:
Comment 5 Mike A. Harris 2003-04-17 22:38:43 EDT
Created attachment 91184 [details]
XFree86-4.2.1-xterm-session-management-resource.patch

Patch to enable session management in xterm by default
Comment 6 Mike A. Harris 2003-04-19 05:22:19 EDT
I have added the XFree86-4.2.1-xterm-session-management-resource.patch
to my latest 4.2.1 build, which will be released soon as official erratum for
Red Hat Linux 7.3 and 8.0.

If presume the patch is ok, however if you have any objections to this patch,
please speak up right away so I have time to make the change.  I don't want
frustrated xterm users, or frustrated upstream maintainers.  ;o)

Thanks Thomas
Comment 7 Thomas E. Dickey 2003-04-19 07:20:36 EDT
sounds fine (if the code doesn't work, they can complain to me)

Note You need to log in before you can comment on or make changes to this bug.