Bug 88774 - P4 with hyperthreading only indicates one CPU
P4 with hyperthreading only indicates one CPU
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-13 19:46 EDT by Dave Goldblatt
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output on Asus P4G8X Deluxe w/BIOS revision 1004 (12.63 KB, text/plain)
2003-04-14 07:14 EDT, Dave Goldblatt
no flags Details
/proc/cpuinfo from P4G8X (453 bytes, text/plain)
2003-04-14 07:15 EDT, Dave Goldblatt
no flags Details
boot log from 2.5.68 detecting HT CPU correctly (12.70 KB, text/plain)
2003-04-26 15:43 EDT, Dave Goldblatt
no flags Details

  None (edit)
Description Dave Goldblatt 2003-04-13 19:46:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030411

Description of problem:
I know additional scheduler support for Intel's hyperthreading is in 2.5.x, but
I was under the impression that the later 2.4.x kernels would detect a
hyperthread-capable CPU as two logical processors; in my case I've got a P4
3.06GHz CPU on an Asus P4G8X which only appears as a single processor under
2.4.20-9smp, though the number of siblings in cpuinfo appears as 2.

Version-Release number of selected component (if applicable):
kernel-2.4.20-9smp

How reproducible:
Always

Steps to Reproduce:
cat /proc/cpuinfo

Notice 2 siblings, yet only one CPU listed; I believe Xeons list two CPUs.    

Additional info:

Hyperthreading is enabled in the BIOS, and Windows XP detects two (logical) CPUs.
Comment 1 Arjan van de Ven 2003-04-14 04:45:37 EDT
this is most likely a bios bug; could you attach the full dmesg output, maybe
that will provide conclusive proof.
Comment 2 Dave Goldblatt 2003-04-14 07:14:35 EDT
Created attachment 91117 [details]
dmesg output on Asus P4G8X Deluxe w/BIOS revision 1004
Comment 3 Dave Goldblatt 2003-04-14 07:15:56 EDT
Created attachment 91118 [details]
/proc/cpuinfo from P4G8X

Just in case..
Comment 4 Arjan van de Ven 2003-04-14 07:17:15 EDT
please try adding acpismp=force to the kernel commandline and see if that helps

also note that systems with the nvidia binary only modules are unsupported.
Comment 5 Dave Goldblatt 2003-04-14 07:30:34 EDT
No luck with the acpismp option.  And yes, I know the non-nv driver isn't
supported; just happened to be trying it that boot - and I'm fairly certain it
doesn't affect the CPU identification code. ;-)

Comment 6 Dave Goldblatt 2003-04-26 15:43:49 EDT
Created attachment 91311 [details]
boot log from 2.5.68 detecting HT CPU correctly

Removed nvidia driver to be supported - same result.

Updated to beta BIOS (1005 beta 1) - same result.

Tried kernel 2.5.68 - both logical CPUs detected; boot log attached (used MADT)
Comment 7 Bugzilla owner 2004-09-30 11:40:47 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.