Bug 88777 - up2date Insists that I "update" kde to version 3.0.3, but I have KDE 3.1.1 installed
up2date Insists that I "update" kde to version 3.0.3, but I have KDE 3.1.1 in...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-13 22:22 EDT by Christoper Crammond
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 16:35:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoper Crammond 2003-04-13 22:22:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
I have an issue/problem with up2date.

Less than a week ago I upgraded my KDE from version 3.0.3 to 3.1.1 via the
Redhat RPMs on kde.org.  Installation went relatively smoothly, although I did
have to use the �-nodeps option a few times to bypass some dependencies [from
the *-devel packages].  And let me mention that I did use the update flag for
rpm when necessary.  Things seem to have gone well and now I am enjoying the
benefits of KDE 3.1.1.  This was not meant to last.  :)

For the first time since I updated KDE, I used up2date.  In addition to some
necessary samba updates, there is a list for the entire KDE 3.0.3 software
suite.  Even though I already have 3.1.1 installed, up2date seems to think that
I need to �update� to version 3.0.3.

So every time I use up2date now I have to pick my way through the entire KDE
3.0.3 catalog before I can get to whatever it is that I need.  I really don't
understand what the problem is since I have, in theory, successful installed KDE
3.1.1.  For curiosity's sake, here is a query of my installed kde programs:

[root@nubby up2date]# rpm -qa | grep kde
kdeartwork-3.1.1-0.8x.1
kdepim-devel-3.1.1-0.8x.1
kdeaddons-3.1.1-0.8x.1
kdebase-3.1.1-0.8x.2
kdegames-3.1.1-0.8x.1
kdetoys-3.1.1-0.8x.1
kdeutils-3.1.1-0.8x.1
kdelibs-3.1.1-0.8x.2
kdebase-devel-3.1.1-0.8x.2
kdebindings-devel-3.1.1-0.8x.1
kdegames-devel-3.1.1-0.8x.1
kdesdk-devel-3.1.1-0.8x.1
kdegraphics-devel-3.1.1-0.8x.1
kdeutils-devel-3.1.1-0.8x.1
lockdev-1.0.0-20
kdelibs-devel-3.1.1-0.8x.2
kdeadmin-3.1.1-0.8x.1
kdeedu-3.1.1-0.8x.1
kdepim-3.1.1-0.8x.1
kdenetwork-3.1.1-0.8x.1
kdemultimedia-3.1.1-0.8x.1
kdevelop-2.1.5-0.8x.1
kdeedu-devel-3.1.1-0.8x.1
kdenetwork-devel-3.1.1-0.8x.1
kdemultimedia-devel-3.1.1-0.8x.1
switchdesk-kde-3.9.8-9
kdebindings-3.1.1-0.8x.1
kdesdk-3.1.1-0.8x.1
kdegraphics-3.1.1-0.8x.1


Version-Release number of selected component (if applicable):
up2date-3.0.7-1

How reproducible:
Always

Steps to Reproduce:
1)  Start with a computer with Redhat 8.0 and KDE 3.0.3
2)  Download the KDE 3.1.1 RPMs from kde.org
3)  Upgrade/install as necessary
4)  Run up2date

Actual Results:  Up2date prompts me to "update" the KDE packages to version 3.0.3.

Expected Results:  Up2date should not ask me to "update" kde, but rather just
give the usually list of out-of-date files.
Comment 1 Adrian Likins 2003-04-15 14:18:54 EDT
Looking though the deps now...

If I had to make a guess, it would be that one or more of the
3.1.1 packages has an incorrect Epoch set, and is causing the
whole set to get downgraded. But thats a guess...

pulling down 3.1.1 now to check the packages...
Comment 2 Adrian Likins 2003-04-15 15:12:48 EDT
On closer inspection, it looks to be an issue with the obsoletes
in the 8.0 packages. Since some of the 8.0 packages were
split up (kdesdk, kdeutils, kdeutils, kdeaddonts,etc) some
of them obsolete packages like kdeutils, kdedsk, kdenetwork.

The up2date in 8.0 attempts to resolve obsoletes (the 3.0.3
packages the server knows about, wants to obsolete "kdenetwork",
which you now have install for example, and eventually leads
to the deps you see...

Sending email to the building of the kde.org packages to
see what we can do to fix that...
Comment 3 Adrian Likins 2003-04-15 15:13:14 EDT
On closer inspection, it looks to be an issue with the obsoletes
in the 8.0 packages. Since some of the 8.0 packages were
split up (kdesdk, kdeutils, kdeutils, kdeaddonts,etc) some
of them obsolete packages like kdeutils, kdedsk, kdenetwork.

The up2date in 8.0 attempts to resolve obsoletes (the 3.0.3
packages the server knows about, wants to obsolete "kdenetwork",
which you now have install for example, and eventually leads
to the deps you see...

Sending email to the building of the kde.org packages to
see what we can do to fix that...

Note You need to log in before you can comment on or make changes to this bug.