Bug 887808 - [RHEVM-SDK] [RFE]: add print of the whole response body and not only its status in debug mode for sdk and cli
[RHEVM-SDK] [RFE]: add print of the whole response body and not only its sta...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2.0
Assigned To: Michael Pasternak
Ilia Meerovich
infra
: FutureFeature
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-12-17 06:55 EST by Ilia Meerovich
Modified: 2016-02-10 14:32 EST (History)
10 users (show)

See Also:
Fixed In Version: SF4
Doc Type: Enhancement
Doc Text:
Debug mode for the Software Development Kit (SDK) and Command Line Interface (CLI) now prints the whole response body, not just the status.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 16:13:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
dyasny: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10433 None None None Never

  None (edit)
Description Ilia Meerovich 2012-12-17 06:55:25 EST
It will ease cli and sdk debug
Comment 1 Michael Pasternak 2012-12-27 08:21:01 EST
http://gerrit.ovirt.org/#/c/10433/
Comment 3 Ilia Meerovich 2013-02-05 05:11:04 EST
verifed with rhevm-cli-3.2.0.3-1.el6ev.noarch:

[imeerovi@imeerovi ART]$ /usr/bin/rhevm-shell -c --url=https://leonid_rhevm.qa.lab.tlv.redhat.com:443/api/ -u admin@internal -I -d

send: 'GET /api HTTP/1.1\r\nHost: leonid_rhevm.qa.lab.tlv.redhat.com\r\nAccept-Encoding: identity\r\nFilter: False\r\nPrefer: persistent-auth\r\nContent-type: application/xml\r\nAuthorization: Basic YWRtaW5AaW50ZXJuYWw6MTIzNDU2\r\n\r\n'
reply: 'HTTP/1.1 200 OK\r\n'
header: Date: Tue, 05 Feb 2013 10:14:38 GMT
header: Pragma: No-cache
header: Cache-Control: no-cache
header: Expires: Thu, 01 Jan 1970 02:00:00 IST
header: Set-Cookie: JSESSIONID=QNqQvHXG68yfy6yVZ-lTSOx0; Path=/api; Secure
header: Link: <https:/api/capabilities>; rel=capabilities,<https:/api/clusters>; rel=clusters,<https:/api/clusters?search={query}>; rel=clusters/search,<https:/api/datacenters>; rel=datacenters,<https:/api/datacenters?search={query}>; rel=datacenters/search,<https:/api/events>; rel=events,<https:/api/events;from={event_id}?search={query}>; rel=events/search,<https:/api/hosts>; rel=hosts,<https:/api/hosts?search={query}>; rel=hosts/search,<https:/api/networks>; rel=networks,<https:/api/roles>; rel=roles,<https:/api/storagedomains>; rel=storagedomains,<https:/api/storagedomains?search={query}>; rel=storagedomains/search,<https:/api/tags>; rel=tags,<https:/api/templates>; rel=templates,<https:/api/templates?search={query}>; rel=templates/search,<https:/api/users>; rel=users,<https:/api/users?search={query}>; rel=users/search,<https:/api/groups>; rel=groups,<https:/api/groups?search={query}>; rel=groups/search,<https:/api/domains>; rel=domains,<https:/api/vmpools>; rel=vmpools,<https:/api/vmpools?search={query}>; rel=vmpools/search,<https:/api/vms>; rel=vms,<https:/api/vms?search={query}>; rel=vms/search,<https:/api/disks>; rel=disks,<https:/api/disks?search={query}>; rel=disks/search
header: Content-Type: application/xml
header: Content-Length: 2460
header: Connection: close
body:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<api>
    <link href="/api/capabilities" rel="capabilities"/>
    <link href="/api/clusters" rel="clusters"/>
    <link href="/api/clusters?search={query}" rel="clusters/search"/>
    <link href="/api/datacenters" rel="datacenters"/>
    <link href="/api/datacenters?search={query}" rel="datacenters/search"/>
    <link href="/api/events" rel="events"/>
    <link href="/api/events;from={event_id}?search={query}" rel="events/search"/>
    <link href="/api/hosts" rel="hosts"/>
    <link href="/api/hosts?search={query}" rel="hosts/search"/>
    <link href="/api/networks" rel="networks"/>
    <link href="/api/roles" rel="roles"/>
    <link href="/api/storagedomains" rel="storagedomains"/>
    <link href="/api/storagedomains?search={query}" rel="storagedomains/search"/>
    <link href="/api/tags" rel="tags"/>
    <link href="/api/templates" rel="templates"/>
    <link href="/api/templates?search={query}" rel="templates/search"/>
    <link href="/api/users" rel="users"/>
    <link href="/api/users?search={query}" rel="users/search"/>
    <link href="/api/groups" rel="groups"/>
    <link href="/api/groups?search={query}" rel="groups/search"/>
    <link href="/api/domains" rel="domains"/>
    <link href="/api/vmpools" rel="vmpools"/>
    <link href="/api/vmpools?search={query}" rel="vmpools/search"/>
    <link href="/api/vms" rel="vms"/>
    <link href="/api/vms?search={query}" rel="vms/search"/>
    <link href="/api/disks" rel="disks"/>
    <link href="/api/disks?search={query}" rel="disks/search"/>
    <special_objects>
        <link href="/api/templates/00000000-0000-0000-0000-000000000000" rel="templates/blank"/>
        <link href="/api/tags/00000000-0000-0000-0000-000000000000" rel="tags/root"/>
    </special_objects>
    <product_info>
        <name>Red Hat Enterprise Virtualization</name>
        <vendor>Red Hat</vendor>
        <version major="3" minor="1" build="0" revision="0"/>
    </product_info>
    <summary>
        <vms>
            <total>0</total>
            <active>0</active>
        </vms>
        <hosts>
            <total>0</total>
            <active>0</active>
        </hosts>
        <users>
            <total>1</total>
            <active>1</active>
        </users>
        <storage_domains>
            <total>3</total>
            <active>0</active>
        </storage_domains>
    </summary>
    <time>2013-02-05T12:14:39.231+02:00</time>
</api>


 ==========================================
 >>> connected to RHEVM manager 3.1.0.0 <<<
 ==========================================


        
 ++++++++++++++++++++++++++++++++++++++++++
 
           Welcome to RHEVM shell
 
 ++++++++++++++++++++++++++++++++++++++++++
        
    
[RHEVM shell (connected)]#
Comment 5 errata-xmlrpc 2013-06-10 16:13:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0912.html

Note You need to log in before you can comment on or make changes to this bug.