Bug 887859 - Incorrect example in anacrontab manpage
Summary: Incorrect example in anacrontab manpage
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cronie
Version: 6.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Marcela Mašláňová
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Keywords: ManPageChange
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-17 13:41 UTC by Branislav Náter
Modified: 2013-11-21 22:24 UTC (History)
2 users (show)

(edit)
Cause: Anacrontab man page has incorrect example (missing 5 where should be 5 minutes for the delay).

Consequence: User might be confused how to set up anacron table.

Fix: 5 is there.

Result: User knows how to set up anacrontab perfectly.
Clone Of:
(edit)
Last Closed: 2013-11-21 22:24:29 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1681 normal SHIPPED_LIVE cronie bug fix and enhancement update 2013-11-20 21:52:35 UTC

Description Branislav Náter 2012-12-17 13:41:31 UTC
Description of problem:
Example in anacrontab doesn't have set "delay" for daily jobs, but it's mentioned in comment above. See bellow.

Version-Release number of selected component (if applicable):
cronie-1.4.4-7.el6

Steps to Reproduce:
1. man anacrontab
2. go to EXAMPLE section
  
Actual results:
RANDOM_DELAY=30
# Anacron jobs will start between 6 and 8 o’clock.
START_HOURS_RANGE=6-8
# delay will be 5 minutes + RANDOM_DELAY for cron.daily
1         0    cron.daily          nice run-parts /etc/cron.daily
7         0    cron.weekly         nice run-parts /etc/cron.weekly

Expected results: (delay is set to 5 minutes for cron.daily)
RANDOM_DELAY=30
# Anacron jobs will start between 6 and 8 o’clock.
START_HOURS_RANGE=6-8
# delay will be 5 minutes + RANDOM_DELAY for cron.daily
1         5    cron.daily          nice run-parts /etc/cron.daily
7         0    cron.weekly         nice run-parts /etc/cron.weekly

Comment 2 Jakub Prokes 2013-09-25 11:01:18 UTC
[root@ibm-p730-04-lp4 ~]# rpm -q cronie-anacron && man -P cat anacrontab | iconv -f utf-8 -t ASCII -c | grep -A 17 EX
cronie-anacron-1.4.4-7.el6.ppc64
EXAMPLE
       This example shows how to set up the behaviour similar to previous set-
       ting  in  /etc/crontab  which  will start all regular jobs only between
       6:00 and 8:00. There is added RANDOM_DELAY which will be  maximally  30
       minutes.  Jobs  will  be  running in queue. After one finish, then next
       will start.

       # environment variables
       SHELL=/bin/sh
       PATH=/sbin:/bin:/usr/sbin:/usr/bin
       MAILTO=root
       RANDOM_DELAY=30
       # Anacron jobs will start between 6 and 8 oclock.
       START_HOURS_RANGE=6-8
       # delay will be 5 minutes + RANDOM_DELAY for cron.daily
       1         0    cron.daily          nice run-parts /etc/cron.daily
       7         0    cron.weekly         nice run-parts /etc/cron.weekly
       @monthly  0    cron.monthly

[root@ibm-p730-02-lp2 ~]# rpm -q cronie-anacron && man -P cat anacrontab | iconv -f utf-8 -t ASCII -c | grep -A 17 EX
cronie-anacron-1.4.4-12.el6.ppc64
EXAMPLE
       This example shows how to set up the behaviour similar to previous set-
       ting  in  /etc/crontab  which  will start all regular jobs only between
       6:00 and 8:00. There is added RANDOM_DELAY which will be  maximally  30
       minutes.  Jobs  will  be  running in queue. After one finish, then next
       will start.

       # environment variables
       SHELL=/bin/sh
       PATH=/sbin:/bin:/usr/sbin:/usr/bin
       MAILTO=root
       RANDOM_DELAY=30
       # Anacron jobs will start between 6 and 8 oclock.
       START_HOURS_RANGE=6-8
       # delay will be 5 minutes + RANDOM_DELAY for cron.daily
       1         5    cron.daily          nice run-parts /etc/cron.daily
       7         0    cron.weekly         nice run-parts /etc/cron.weekly
       @monthly  0    cron.monthly        nice run-parts /etc/cron.monthly

Comment 3 errata-xmlrpc 2013-11-21 22:24:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1681.html


Note You need to log in before you can comment on or make changes to this bug.