Bug 88793 - Anaconda crashes after switching to X Windows during normal installation
Summary: Anaconda crashes after switching to X Windows during normal installation
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-14 08:43 UTC by Bart Boelaert
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-23 14:57:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bart Boelaert 2003-04-14 08:43:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I try to install RH8.0 on a system with the following specs :
- AMD Athlon - 500 MHz
- 256 MB RAM
- 3Ware ATA RAID Controller : Escalade 7000-2, containing 2
  HDD (MAXTOR 6L080J4, 80 GB)
- Adaptec AHA-2940 Ultra SCSI controller with 3 CD-ROMS (Plexttor UltraPlex 
40Max) and 3 DVD-ROMS (Pioneer DVD-303)

I install the system booting from the RedHat CD-ROM. The CD-ROM media test is 
successful. Short after the installer switches to X Windows (after successfully 
probing the video card, mouse and monitor) and briefly showing the RedHat logo, 
the install routine breaks with the follwing console messages :

Traceback (most recent call last):
File "/usr/bin/anaconda", line 639, in ?
  iutil.makeDriveDeviceNodes()
File "/usr/lib/anaconda/iutil.py", line 420, in makeDriveDeviceNodes
  isys.makeDevInode(drive,"/dev/%s" % (drive,))
File "/usr/lib/anaconda/isys.py", line 265, in makeDevInode
  _isys.mkdevinode(name,fn)
SystemError: (2, 'No such file or directory')
install exited abnormally

Can somebody help me out?

Kind regards,

Bart.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from SCSI CD-ROM on a system using a 3Ware controller
2. Launch install using the GUI or text mode
    

Additional info:

Comment 1 Michael Fulbright 2003-04-15 16:38:43 UTC
Mike do we have a 3Ware setup like this to test with?

Comment 2 Bart Boelaert 2003-04-15 16:58:45 UTC
For completeness :
- The main board is Asus K7M with AMI BIOS from 08/02/2000
- After upgrading the BIOS and the firmware of the Adaptec host adapter
  the install error still remains
- Launching the installation with the "nodma" and "noprobe" kernel parameter
  did not solve the error either
- FirmWare versions info :
   * 3Ware ATA RAID controller : FE7X 1.05.00.036
   * Adaptec AHA-2940 host adapter : v2.20.0




Comment 3 Michael Fulbright 2003-09-29 15:39:59 UTC
Mike have you been able to take a look and see if we have this test
configuration available?

Comment 4 Jeremy Katz 2003-10-23 14:57:40 UTC
This is a dupe of another bug where we mishandled having more than 2
scsi cdrom drives.  It's fixed in newer releases.


Note You need to log in before you can comment on or make changes to this bug.