This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 887957 - [ml_IN] pofilter newlines test failed for msgid="Redeeming the subscription may take..."
[ml_IN] pofilter newlines test failed for msgid="Redeeming the subscription m...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481
  Show dependency treegraph
 
Reported: 2012-12-17 12:02 EST by John Sefler
Modified: 2013-02-21 04:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:04:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-12-17 12:02:19 EST
Description of problem:

# (pofilter) newlines: Different line endings
msgid ""
"Redeeming the subscription may take a few minutes.\n"
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr "സബ്സ്ക്രിപ്ഷന്‍ ലഭ്യമാക്കുന്നതിനു് ആല്‍പം സമയമെടുക്കുന്നു.¶ ഇതു് പൂര്‍ത്തിയാക്കുമ്പോള്‍ അറിയിയ്ക്കുന്നതിനുള്ള¶ ഈമെയില്‍ വിലാസം നല്‍കുക."

^^ NOTICE IN THE msgstr TRANSLATIONS THAT THE "¶" CHARACTER WAS USED INSTEAD OF "\n".  THIS CAUSES RENDERRING PROBLEMS ESPECIALLY IN FIRSTBOOT.  SEE ATTACHED SCREENSHOT.

Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.15-1.el6.x86_64



Additional info:
https://engineering.redhat.com/rt/Ticket/Display.html?id=180944
Comment 1 Ani Peter 2012-12-18 02:06:53 EST
Have removed the "¶" character and fixed the translations.
https://translate.zanata.org/zanata/iteration/files/subscription-manager/1.1.X/ml

Thanks
Ani
Comment 4 John Sefler 2012-12-21 14:37:53 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64

> [root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/ml/LC_MESSAGES/rhsm.mo | grep -B1 -A7 "Redeeming"
> msgid ""
> "Redeeming the subscription may take a few minutes.\n"
> "Please provide an email address to receive notification\n"
> "when the redemption is complete."
> msgstr ""
> "സബ്സ്ക്രിപ്ഷന്‍ ലഭ്യമാക്കുന്നതിനു് ആല്‍പം സമയമെടുക്കുന്നു.\n"
> "ഇതു് പൂര്‍ത്തിയാക്കുമ്പോള്‍ അറിയിയ്ക്കുന്നതിനുള്ള ഈമെയില്‍ \n"
> "വിലാസം നല്‍കുക."
> 
> [root@jsefler-6 ~]# 

VERIFIED

> [root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/ml/LC_MESSAGES/rhsm.mo > /tmp/rhsm.po
> [root@jsefler-6 ~]# pofilter -t newlines /tmp/rhsm.po
> processing 1 files...
> [###########################################] 100%
> [root@jsefler-6 ~]# 

VERIFIED: pofilter newlines test passes for lang=ml
Comment 6 errata-xmlrpc 2013-02-21 04:04:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.