Bug 887966 - [es_ES] pofilter newlines test failed for msgid="Redeeming the subscription may take..."
[es_ES] pofilter newlines test failed for msgid="Redeeming the subscription m...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481 895654
  Show dependency treegraph
 
Reported: 2012-12-17 12:28 EST by John Sefler
Modified: 2013-02-21 04:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:04:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
consequence of pofilter newlines test failed - dialog wider than firstboot (12.08 KB, image/png)
2012-12-17 12:30 EST, John Sefler
no flags Details

  None (edit)
Description John Sefler 2012-12-17 12:28:06 EST
Description of problem:

# (pofilter) newlines: Different line endings
msgid ""
"Redeeming the subscription may take a few minutes.\n"
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr "Redimir una suscripción puede tardar unos minutos. Por favor provea una dirección de correo-e para recibir notificación cuando la redención se complete. "

THE NEWLINE "\n" CHARACTERS WERE EXCLUDED IN THE TRANSALTION.  THIS CAUSES A PROBLEM WHEN RENDERING THE REDEMPTION DIALOG ESPECIALLY IN FIRSTBOOT.  SEE THE ATTACHED SCREENSHOT.

Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.1.15-1.el6.x86_64


Additional info:
https://engineering.redhat.com/rt/Ticket/Display.html?id=180936
Comment 1 John Sefler 2012-12-17 12:30:00 EST
Created attachment 664995 [details]
consequence of pofilter newlines test failed - dialog wider than firstboot
Comment 4 John Sefler 2012-12-19 15:17:47 EST
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64


# (pofilter) newlines: Different line endings
msgid "Invalid argument specified: %s\n"
msgstr ""
"El argumento especificado es inválido: %s\n"
"\n"

^^^^ THERE IS AN EXTRANEOUS NEWLINE AT THE END OF THIS MSGSTR

Moving bug status back to NEW
Comment 5 Adrian Likins 2013-01-04 13:05:01 EST
(In reply to comment #4)
> [root@jsefler-6 ~]# rpm -q subscription-manager
> subscription-manager-1.1.18-1.el6.x86_64
> 
> 
> # (pofilter) newlines: Different line endings
> msgid "Invalid argument specified: %s\n"
> msgstr ""
> "El argumento especificado es inválido: %s\n"
> "\n"
> 
> ^^^^ THERE IS AN EXTRANEOUS NEWLINE AT THE END OF THIS MSGSTR

Fixed this upstream in zanata. Should be in 1.1.19
Comment 6 John Sefler 2013-01-08 16:26:46 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.20-1.el6.x86_64


[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/es_ES/LC_MESSAGES/rhsm.mo > /usr/share/locale/es_ES/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter -t newlines /usr/share/locale/es_ES/LC_MESSAGES/rhsm.poprocessing 1 files...
[###########################################] 100%

VERIFIED: pofilter newlines test is now passing for LANG=es_ES



[root@jsefler-6 ~]# msgunfmt --no-wrap /usr/share/locale/es_ES/LC_MESSAGES/rhsm.mo | grep -A2 "Invalid argument specified"
msgid "Invalid argument specified.\n"
msgstr "El argumento especificado es inválido.\n"

msgid "Invalid argument specified: %s\n"
msgstr "El argumento especificado es inválido: %s\n"

[root@jsefler-6 ~]# 

VERIFIED
Comment 8 errata-xmlrpc 2013-02-21 04:04:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.