This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 887989 - [de_DE] pofilter newlines test failed on msgid "Redeeming the subscription may take..."
[de_DE] pofilter newlines test failed on msgid "Redeeming the subscription ma...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481 888457
  Show dependency treegraph
 
Reported: 2012-12-17 13:53 EST by John Sefler
Modified: 2013-02-21 04:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:04:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
consequence of pofilter newlines test failed - wide dialog that may exceed firstboot screen width (15.51 KB, image/png)
2012-12-17 13:53 EST, John Sefler
no flags Details

  None (edit)
Description John Sefler 2012-12-17 13:53:58 EST
Created attachment 665048 [details]
consequence of pofilter newlines test failed - wide dialog that may exceed firstboot screen width

Description of problem:


# (pofilter) newlines: Different line endings
msgid ""
"Redeeming the subscription may take a few minutes.\n"
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr "Das Einlösen der Subskription kann ggf. einige Minuten dauern. Bitte geben Sie eine E-Mail-Adresse an, an die eine Benachrichtigung gesendet werden kann, sobald die Subskription erfolgreich eingelöst wurde."


THE msgstr NEGLECTS TO INCLUDE THE NEWLINE "\n" CHARACTERS IN THE TRANSLATION.  THIS CAUSED WIDE DIALOG PROBLEMS.  SEE ATTACHED SCREENSHOT.

Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.15-1.el6.x86_64


Additional info:
https://engineering.redhat.com/rt/Ticket/Display.html?id=180935
Comment 1 Hedda Peters 2012-12-17 18:05:06 EST
Fixed for de-DE in https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.1.X 

BTW, to avoid this issue in the future, I raised a bug against Zanata requesting these newline characters to be made more obvious, since many of us translators apparently overlooked them: https://bugzilla.redhat.com/show_bug.cgi?id=888055
Comment 3 John Sefler 2012-12-21 17:18:40 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64

[root@jsefler-6 ~]# msgunfmt --no-wrap  /usr/share/locale/de_DE/LC_MESSAGES/rhsm.mo > /usr/share/locale/de_DE/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# pofilter -t newlines /usr/share/locale/de_DE/LC_MESSAGES/rhsm.po
processing 1 files...
[###########################################] 100%

^ VERIFIED: PASSED pofilter newlines test


[root@jsefler-6 ~]# grep -B1 -A7 "Redeeming the subscription" /usr/share/locale/de_DE/LC_MESSAGES/rhsm.po
msgid ""
"Redeeming the subscription may take a few minutes.\n"
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr ""
"Das Einlösen der Subskription kann ggf. einige Minuten dauern. \n"
"Bitte geben Sie eine E-Mail-Adresse an, an die eine Benachrichtigung \n"
"gesendet werden kann, sobald die Subskription erfolgreich eingelöst wurde."

[root@jsefler-6 ~]# 


^ VERIFIED: newline characters have been included in the msgstr
Comment 5 errata-xmlrpc 2013-02-21 04:04:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.