Bug 887995 - [fr_FR] pofilter newlines test failed for msgid "Redeeming the subscription..."
[fr_FR] pofilter newlines test failed for msgid "Redeeming the subscription..."
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: Translation
Depends On:
Blocks: 771481 888457
  Show dependency treegraph
 
Reported: 2012-12-17 14:22 EST by John Sefler
Modified: 2013-02-21 04:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:04:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
consequence of pofilter newlines test failed - wide dialog that may exceed firstboot screen width (15.54 KB, image/png)
2012-12-17 14:22 EST, John Sefler
no flags Details

  None (edit)
Description John Sefler 2012-12-17 14:22:09 EST
Description of problem:

# (pofilter) newlines: Different line endings
msgid ""
"Redeeming the subscription may take a few minutes.\n"
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr "l'échange d'un abonnement peut prendre quelques minutes. Veuillez fournir une adresse email pour recevoir une notification lorsque l'échange est terminé."

PLEASE INCLUDE THE NEWLINE CHARACTERS, "\n", IN THE TRANSLATION, OTHERWISE THE DIALOG THAT EMPLOYS THIS MESSAGE WILL RENDER TOO WIDE (ESPECIALLY IN FIRSTBOOT).

SEE SCREENSHOT.


Version-Release number of selected component (if applicable):
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.15-1.el6.x86_64


Additional info:
https://engineering.redhat.com/rt/Ticket/Display.html?id=180937
Comment 1 John Sefler 2012-12-17 14:22:54 EST
Created attachment 665062 [details]
consequence of pofilter newlines test failed - wide dialog that may exceed firstboot screen width
Comment 2 Hedda Peters 2012-12-17 19:36:26 EST
Fixed by french translator in https://translate.zanata.org/zanata/iteration/view/subscription-manager/1.1.X
Comment 4 John Sefler 2012-12-21 17:22:48 EST
Verifying Version...
[root@jsefler-6 ~]# rpm -q subscription-manager
subscription-manager-1.1.18-1.el6.x86_64

[root@jsefler-6 ~]# msgunfmt --no-wrap  /usr/share/locale/fr/LC_MESSAGES/rhsm.mo > /usr/share/locale/fr/LC_MESSAGES/rhsm.po
[root@jsefler-6 ~]# grep -B1 -A7 "Redeeming the subscription" /usr/share/locale/fr/LC_MESSAGES/rhsm.po
msgid ""
"Redeeming the subscription may take a few minutes.\n"
"Please provide an email address to receive notification\n"
"when the redemption is complete."
msgstr ""
"l'échange d'un abonnement peut prendre quelques minutes. \n"
"Veuillez fournir une adresse email pour recevoir une notification\n"
"lorsque l'échange est terminé."


^ VERIFIED: newline characters have been included in the msgstr
Comment 6 errata-xmlrpc 2013-02-21 04:04:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.