Bug 887996 - liveinst fails in f18 Soas TC3 Could not open x display - no protocol specified
liveinst fails in f18 Soas TC3 Could not open x display - no protocol specified
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-12-17 14:26 EST by satellitgo
Modified: 2013-01-02 16:52 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 16:52:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen for TC3 liveinst in root terminal (530.84 KB, image/jpeg)
2012-12-17 18:44 EST, satellitgo
no flags Details
anaconda-log after try to start in Soas-TC3 (624.46 KB, image/jpeg)
2012-12-17 18:45 EST, satellitgo
no flags Details
liveinst working in Soas-remix with switched %include (72.12 KB, image/png)
2012-12-18 01:36 EST, satellitgo
no flags Details

  None (edit)
Description satellitgo 2012-12-17 14:26:52 EST
Description of problem:
liveinst fails in f18 Soas TC3 Could not open x display - no protocol specified
runtime error: GTK could not initialize
Version-Release number of selected component (if applicable):
Fedora-18-TC3-x86_64-Live-SoaS.iso
dd to USB stick and booted

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
liveinst fails in f18 Soas TC3 Could not open x display
runtime error: GTK could not initialize
Expected results:
Install with anaconda 18.37.3 to work

Additional info:
Comment 1 Adam Williamson 2012-12-17 14:47:49 EST
Discussed at 2012-12-17 NTH review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-17/f18final-blocker-review-5.2012-12-17-16.40.log.txt . Accepted as NTH as a critical bug in a non-blocking spin.
Comment 2 satellitgo 2012-12-17 15:00:32 EST
http://bugs.sugarlabs.org/ticket/4342
Comment 3 Chris Lumens 2012-12-17 15:41:33 EST
Please attach /tmp/anaconda.log, /tmp/X.log, and /var/log/syslog to this bug report as individual, uncompressed, files.
Comment 4 satellitgo 2012-12-17 18:44:35 EST
Created attachment 665167 [details]
screen for TC3 liveinst in root terminal
Comment 5 satellitgo 2012-12-17 18:45:34 EST
Created attachment 665177 [details]
anaconda-log after try to start in Soas-TC3
Comment 6 satellitgo 2012-12-17 18:50:06 EST
sugar 0.98.1 has a bug where copy/paste to clipboard crashes sugar
 http://bugs.sugarlabs.org/ticket/4312
So there is no other way to get this information from a live CD with no persistence but with a camera. I have submitted 2 attachemnts.
 /tmp/X.log, and /var/log/syslog were not present
Comment 7 satellitgo 2012-12-17 18:51:31 EST
Soas TC2 Soas worked can you diff the spin-kisckstarts?
Comment 8 Brian Lane 2012-12-17 19:56:53 EST
Something isn't right with X, notice the error from xhost saying it cannot connect to :0

I expect something is wrong with the kickstart, or the packages used to compose it.
Comment 9 Adam Williamson 2012-12-17 20:10:53 EST
As I usually note in these cases - remember SoaS is the _only_ major spin based off of minimal.ks and not live-base.ks . This is usually the cause when it diverges from the other spins in odd ways.
Comment 10 satellitgo 2012-12-17 23:57:32 EST
(In reply to comment #9)
> As I usually note in these cases - remember SoaS is the _only_ major spin
> based off of minimal.ks and not live-base.ks . This is usually the cause
> when it diverges from the other spins in odd ways.

I am trying a Remix using live-base.ks to see if that solves problem
Comment 11 satellitgo 2012-12-18 01:32:29 EST
(In reply to comment #10)
> (In reply to comment #9)
> > As I usually note in these cases - remember SoaS is the _only_ major spin
> > based off of minimal.ks and not live-base.ks . This is usually the cause
> > when it diverges from the other spins in odd ways.
> 
> I am trying a Remix using live-base.ks to see if that solves problem

YES - pointing the Soas-live.ks to %include live-base.ks fixed it
Soas-Remix is 731.9 MB
.iso boots properly to sugar via GDM Live User.
liveinst has all languages now showing correctly
and installs to VirtualBox HD

How can this get fixed in builds?
Comment 12 satellitgo 2012-12-18 01:36:04 EST
Created attachment 665306 [details]
liveinst working in Soas-remix with switched %include
Comment 13 Adam Williamson 2012-12-18 01:38:42 EST
well, we'd need to isolate the missing package. a diff of the package lists of the two images would likely help.
Comment 14 satellitgo 2012-12-18 01:46:40 EST
why not just edit Soas.ks to point to the live-base.ks? one line fix
Comment 15 Adam Williamson 2012-12-18 02:00:43 EST
it would 'fix' this but possibly change all kinds of other things about the spin, which its owners don't necessarily want changed.
Comment 16 Peter Robinson 2012-12-18 11:38:38 EST
(In reply to comment #9)
> As I usually note in these cases - remember SoaS is the _only_ major spin
> based off of minimal.ks and not live-base.ks . This is usually the cause
> when it diverges from the other spins in odd ways.

It was updated to use live-base a couple of weeks ago (sometime between TC1 and TC2). The TC releases are generated from git not from the rpm. It's fixed in git.
Comment 18 Adam Williamson 2012-12-18 19:12:28 EST
bit late, but let's cross our fingers and hope. funnily, if this was done on 12-10, wouldn't that be between tc2 and tc3 - so this change actually *broke* it, somehow, rather than fixing it? /me now officially confused
Comment 19 Peter Robinson 2012-12-19 01:11:25 EST
(In reply to comment #18)
> bit late, but let's cross our fingers and hope. funnily, if this was done on
> 12-10, wouldn't that be between tc2 and tc3 - so this change actually
> *broke* it, somehow, rather than fixing it? /me now officially confused

Well there wasn't a TC2 that I could find when I made the changes and I was testing by generating images. TC1 was pulling in all of the gnome desktop so it was large.
Comment 20 Ray Strode [halfline] 2012-12-20 16:57:55 EST
should be fixed by https://admin.fedoraproject.org/updates/gdm-3.6.2-5.fc18

See bug 887816
Comment 21 Fedora Update System 2012-12-20 16:58:42 EST
gdm-3.6.2-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gdm-3.6.2-5.fc18
Comment 22 Fedora Update System 2012-12-20 20:33:18 EST
Package gdm-3.6.2-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gdm-3.6.2-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20736/gdm-3.6.2-5.fc18
then log in and leave karma (feedback).
Comment 23 Fedora Update System 2013-01-02 16:52:21 EST
gdm-3.6.2-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.