Bug 888005 - Setup for redundant proxy fails to use secondary proxy
Setup for redundant proxy fails to use secondary proxy
Status: CLOSED DUPLICATE of bug 873784
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs User Guide (Show other bugs)
541
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: David O'Brien
:
Depends On:
Blocks: 819027 922607
  Show dependency treegraph
 
Reported: 2012-12-17 14:50 EST by Michael Hood
Modified: 2013-06-27 07:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 07:16:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Hood 2012-12-17 14:50:19 EST
Description of problem:

WHen customer tries to set up redundant proxy by follwoing the user guide it fails to use the secondary proxy.


Version-Release number of selected component (if applicable):
5.4.1


How reproducible:


Steps to Reproduce:
1. Here is the proxy setup doc for 5.4.1.

https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Network_Satellite/5.4/html/Proxy_Installation_Guide/index.html

serverURL=https://proxy1/XMLRPC;
serverURL=https://proxy2/XMLRPC;
serverURL=https://satellite_server/XMLRPC;

would overwrite serverURL with the new value each time. try

serverURL="https://proxy1/XMLRC; https://proxy2/XMLRPC; https://satellite_server/XMLRPC"

I'm testing it right now, will edit this again when done -- done

no that does not work on RHEL6 - I do not think this feature was kept with RHEL6.

I think we should rather focus on the problem affecting the proxy here.

also confirmed not to work for RHEL5. the yum-rhn-plugin stops at the first value ; the only way around that would be to change the value.

if the customer needs this we can raise a bug if that documentation is still in RHEL5.8 but otherwise we would look into a RHEL6 RFE

  
Actual results:

The service will not use the secondary proxy in the config.


Expected results:


Additional info:
Comment 5 Dimitar Yordanov 2013-06-27 07:16:37 EDT
Hi all,
  
  The key of your troubles is the missing semicolon at the end of line as described in the documentation.
  serverURL="https://proxy1/XMLRC; https://proxy2/XMLRPC; https://satellite_server/XMLRPC;"

  We are aware that it is easy to get confused so we addressed the issue in 
Spacewalk master: 6b937b2d876e4d025f62785ab4b9af807cc71c50 (rhn-client-tools-1.10.11-1) in order the semicolon at the end of the line not to be obligatory.

for more info please see:
  https://bugzilla.redhat.com/show_bug.cgi?id=873784

Dimi

*** This bug has been marked as a duplicate of bug 873784 ***

Note You need to log in before you can comment on or make changes to this bug.