Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 888051 - Button field on touchpad working as touchpad - making actually hitting something difficult
Summary: Button field on touchpad working as touchpad - making actually hitting someth...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics
Version: 18
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-17 22:27 UTC by Andreas-Johann Ulvestad
Modified: 2013-01-12 01:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-12 01:08:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Andreas-Johann Ulvestad 2012-12-17 22:27:23 UTC
Description of problem:
I have a Zenbook UX32VD with a pretty well-working touchpad... but there is one issue annoyng the hell out of me and friends with the same laptop: actually using the dedicated clickable buttons is almost impossible under Fedora 18!

The buttons are a part of the touchpad. Under FEdora, they can also be used as a touchpad. Actually hitting a small button, or doing tasks as resizing a window.. or anything else not including pressing a gigantic button is impossible because the mouse cursor shifts a bit when you click the buttons. If you are lucky you are hitting the buttons from directly above, minimizing this, but if you shift your finger a fraction of a millimeter... you miss. Again and again and again.

Version-Release number of selected component (if applicable):
xorg-x11-drv-synaptics-1.6.2.7-fc18.i686

How reproducible:
Every time (ish)

Steps to Reproduce:
1. Hover over something you want to click
2. Try to click it with the buttons (eg right click)
3. If you're not extremely lucky, the cursor will shift slightly, and you miss.

Comment 1 Peter Hutterer 2012-12-20 23:11:50 UTC
Pop this into /etc/X11/xorg.conf.d/99-synaptics-dontgrab.conf

Section "InputClass"
        Identifier "Don't grab synaptics"
        MatchDriver "synaptics"
        Option "GrabEventDevice" "off"
EndSection

Then restart the server. Install evemu, and get an evemu-record output for your touchpad when you trigger the bug. Please make that recording as short as possible, i.e. if you don't trigger the bug with a click, cancel and restart evemu-record. More info here: http://people.freedesktop.org/~whot/evemu/

Attach both the device description and the event recording here

Comment 2 Peter Hutterer 2012-12-21 00:12:16 UTC
Actually, not sure we can easily fix this as we don't necessarily know if the button will be pressed in the future. The best option here is to limit the area to outside of those buttons.

xinput list-props "SynPS/2 Synaptics TouchPad"
look for "Synaptics Soft Button Areas", it'll say something like this:

 Synaptics Soft Button Areas (341):	3472, 0, 3900, 0, 0, 0, 0, 0

the third value is the top edge of the button. Then set the dead area to anything below that button.

  xinput set-prop "SynPS/2 Synaptics TouchPad" "Synaptics Area" 0 0 0 3900


Your device may have a different name, use xinput list to find out the name.

to make this configuration permanent, write an xorg.conf.d snippet setting Option AreaBottomEdge with the value you found most convenient.

Comment 3 Fedora Update System 2012-12-21 02:39:22 UTC
xorg-x11-drv-synaptics-1.6.2-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xorg-x11-drv-synaptics-1.6.2-8.fc18

Comment 4 Fedora Update System 2012-12-21 20:03:11 UTC
Package xorg-x11-drv-synaptics-1.6.2-8.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-synaptics-1.6.2-8.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20817/xorg-x11-drv-synaptics-1.6.2-8.fc18
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2013-01-12 01:08:12 UTC
xorg-x11-drv-synaptics-1.6.2-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.