Bug 888065 - pidgin doesn't prompt for password after update to pidgin-sipe 1.14.0-1
Summary: pidgin doesn't prompt for password after update to pidgin-sipe 1.14.0-1
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pidgin-sipe
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stefan Becker
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-17 23:15 UTC by Chad Feller
Modified: 2013-01-12 00:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-18 03:10:33 UTC
Type: Bug


Attachments (Terms of Use)

Description Chad Feller 2012-12-17 23:15:17 UTC
Description of problem:
After update to pidgin-sipe/purple-sipe 1.14.0-1, pidgin no longer prompts me for my Communicator password.  Instead it just fails with "Password required'.  Pidgin debug window shows the following:

(15:06:17) account: Connecting to account foo@bar.com,foo@bar.com.
(15:06:17) connection: Connecting. gc = 0x1367710
(15:06:17) connection: Connection error on 0x1367710 (reason: 2 description: Password required)

Version-Release number of selected component (if applicable):
pidgin-sipe-1.14.0-1.fc18.x86_64
purple-sipe-1.14.0-1.fc18.x86_64
pidgin-2.10.6-4.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1. Have a communicator profile w/out a saved password
2. try to sign in
3.
  
Actual results:
sign in fails, without prompting for password

Expected results:
pidgin should prompt for password


Additional info:
Previous version(s) of pidgin-sipe/purple-sipe would prompt for password.  1.13.3-1 had no such issue.

Comment 1 Stefan Becker 2012-12-18 03:10:33 UTC
This is an intentional change, because Kerberos Single Sign-On users don't want to enter a password.

As Pidgin does not know how to handle protocol plugins that can have password and password-less modes I opted for a compromise: if a password is required then the account setup will fail immediately with the error message "Password required".

You'll have to save a password with the account. Closing as NOTABUG.

Comment 2 Chad Feller 2012-12-18 19:01:19 UTC
This is problematic as Pidgin saves the password in plaintext in ~/.purple/accounts.xml.

There is a "Use Single Sign-On" setting checkbox under the advanced tab.  Is there a way to make it check that setting first, and only not prompt for a password if that checkbox is set?

Comment 3 Stefan Becker 2012-12-18 19:15:11 UTC
No, there is no such way, because Pidgin opens the password request based on the compiled-in hard-coded "password is optional" plugin flag not being set *BEFORE* calling the account.

The previous solution annoyed Single Sign-On users and several times they simply submitted a git commit to set that flag in the plugin code, which I had then to revert. This compromise is currently the best solution.

I just checked the API documentation and there might be a possible work around.

Comment 4 Stefan Becker 2012-12-18 21:50:12 UTC
If you are interested, please check out the alternative implementation for Pidgin password-less support from git commit a1fd830. This will be included in the next release.

Comment 5 Fedora Update System 2012-12-26 15:48:08 UTC
pidgin-sipe-1.14.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.14.1-1.fc18

Comment 6 Fedora Update System 2012-12-26 15:49:00 UTC
pidgin-sipe-1.14.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.14.1-1.fc17

Comment 7 Fedora Update System 2012-12-26 15:49:45 UTC
pidgin-sipe-1.14.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/pidgin-sipe-1.14.1-1.fc16

Comment 8 Fedora Update System 2013-01-05 06:33:44 UTC
pidgin-sipe-1.14.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-01-05 06:50:08 UTC
pidgin-sipe-1.14.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-01-12 00:12:21 UTC
pidgin-sipe-1.14.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.