Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 888084 - installing grub, incorrect command
Summary: installing grub, incorrect command
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: install-guide
Version: devel
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Bokoc
QA Contact: Ruediger Landmann
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-18 00:17 UTC by Chris Murphy
Modified: 2013-07-29 17:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-29 17:00:24 UTC


Attachments (Terms of Use)

Description Chris Murphy 2012-12-18 00:17:50 UTC
Description of problem:
E.3. example command to install GRUB is incorrect.

Version-Release number of selected component (if applicable):
Fedora 18


Steps to Reproduce:
1. http://docs.fedoraproject.org/en-US/Fedora/17/html/Installation_Guide/s1-grub-installing.html

2. Center of document command grub-install /dev/hda

  
Actual results:
grub-install /dev/hda

Expected results:

BIOS:
grub2-install /dev/hda

UEFI:
grub2-install

Note that on BIOS, a device needs to be qualified. On UEFI it doesn't, the assumption is based on the currently mounted system.

Additional info 1:
Since GRUB Legacy is now totally dropped from Fedora as of 18, the usage of grub2-install and grub2-mkconfig should use upstream's naming (i.e. drop the 2). So these commands will change yet again, unclear when.

Comment 1 Jack Reed 2013-01-08 05:18:11 UTC
Thanks Chris. I've edited the command and indicated that <location> is not required on EFI systems.


Note You need to log in before you can comment on or make changes to this bug.