Bug 888089 - ValueError: A RAID0 set requires at least 2 members
ValueError: A RAID0 set requires at least 2 members
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:dc1e8e7bf48151b5568b3652cd5...
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-12-17 19:33 EST by Chris Murphy
Modified: 2013-01-08 16:33 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 16:33:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (357.25 KB, text/plain)
2012-12-17 19:33 EST, Chris Murphy
no flags Details
File: anaconda.log (15.59 KB, text/plain)
2012-12-17 19:33 EST, Chris Murphy
no flags Details
File: environ (868 bytes, text/plain)
2012-12-17 19:33 EST, Chris Murphy
no flags Details
File: ifcfg.log (379 bytes, text/plain)
2012-12-17 19:33 EST, Chris Murphy
no flags Details
File: messages (139.08 KB, text/plain)
2012-12-17 19:33 EST, Chris Murphy
no flags Details
File: program.log (42.93 KB, text/plain)
2012-12-17 19:33 EST, Chris Murphy
no flags Details
File: storage.log (156.73 KB, text/plain)
2012-12-17 19:33 EST, Chris Murphy
no flags Details
anaconda-tb-qjilrm (509.10 KB, text/plain)
2013-01-02 19:01 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2012-12-17 19:33:18 EST
Description of problem:
Set /boot to RAID device with optimization (i.e. RAID 0).
The following was filed automatically by anaconda:
anaconda 18.37.3 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 2667, in __init__
    {"raidLevel": self.level, "minMembers": mdraid.get_raid_min_members(self.level)}
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1068, in newMDArray
    return MDRaidArrayDevice(name, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 3324, in new_device
    return getattr(self.storage, self.new_device_attr)(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 3509, in new_device
    return super(MDFactory, self).new_device(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 2283, in newDevice
    **kwa)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 866, in _replace_device
    self.__storage.newDevice(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1084, in _save_right_side
    selector=selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2120, in on_selector_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 195, in _onSelectorClicked
    cb(selector)
ValueError: A RAID0 set requires at least 2 members

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=Fedora-18-TC3-x86_64-Live-Deskto rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.10-4.fc18.x86_64
other involved packages: 
package:        anaconda-18.37.3-1.fc18.x86_64
packaging.log:  
product:        Fedora
release:        Fedora release 18 (Spherical Cow)
type:           libreport
version:        18
Comment 1 Chris Murphy 2012-12-17 19:33:21 EST
Created attachment 665206 [details]
File: anaconda-tb
Comment 2 Chris Murphy 2012-12-17 19:33:23 EST
Created attachment 665207 [details]
File: anaconda.log
Comment 3 Chris Murphy 2012-12-17 19:33:25 EST
Created attachment 665208 [details]
File: environ
Comment 4 Chris Murphy 2012-12-17 19:33:26 EST
Created attachment 665209 [details]
File: ifcfg.log
Comment 5 Chris Murphy 2012-12-17 19:33:28 EST
Created attachment 665210 [details]
File: messages
Comment 6 Chris Murphy 2012-12-17 19:33:29 EST
Created attachment 665211 [details]
File: program.log
Comment 7 Chris Murphy 2012-12-17 19:33:31 EST
Created attachment 665212 [details]
File: storage.log
Comment 8 Chris Murphy 2012-12-17 19:58:27 EST
Steps to reproduce:
1. Two new virtual disks.
2. Launch installer > Installation Destination > Choose both disks.
3. Choose "customize the partitioning" checkbox to go to Manual Partitioning.
4. Manual Partitioning, click "click here to create them automatically"
5. Boot is already selected, click on Customize > Device Type set to RAID.
6. Click on Root


Results: Crash

Expected: a.) Don't let me do invalid things; or b.) don't crash.


Regression: If I do it this way, it works (doesn't crash, installs, and boots.)
1. click on swap, set to standard partitioning, apply changes.
2. click on root, set to RAID0, apply changes.
3. click on boot, set to RAID0, apply changes.


Additional info: Proposing as blocker:
F18 Beta Release Criterion #11: must be able to install to RAID-0 *except* for /boot. i.e. it is obviously an invalid operation.

F18 Beta Release Criterion #10: Installer should... Reject obviously invalid operations without crashing.
Comment 9 David Lehman 2012-12-18 11:13:42 EST
The device is switched to md, but one of the two disks has no free space so it fails. We need to catch this exception so it can be handled cleanly.
Comment 10 Chris Murphy 2012-12-18 12:45:18 EST
Sounds like another bug because both disks have only free space, not partitioned, and are identical in size.
Comment 11 Adam Williamson 2012-12-19 12:32:00 EST
Discussed at 2012-12-19 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-19/f18final-blocker-review-6.2012-12-19-17.02.log.txt . Accepted as a blocker per criterion "The installer's custom partitioning mode must be capable of the following ... Rejecting obviously invalid operations without crashing".
Comment 12 Adam Williamson 2013-01-02 15:06:56 EST
So, the patch looks to have been acked:

https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-December/002581.html

but never pushed to f18-branch:

http://git.fedorahosted.org/cgit/anaconda.git/log/?h=f18-branch

I don't see it there.

David, Brian, why the hold-up in pushing this? Can it please get pushed? Thanks.
Comment 13 Brian Lane 2013-01-02 15:12:58 EST
That patch referred to the wrong bz#. It was pushed with the right one, bug 885378
Comment 14 Jaroslav Reznik 2013-01-02 18:19:36 EST
(In reply to comment #13)
> That patch referred to the wrong bz#. It was pushed with the right one, bug
> 885378

Well, this looks like a correct one - https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-December/002578.html and got acked (ValueError to DeviceError to catch the exception as mentioned above in comment #9), the one you refer to is [PATCH 2/3].
Comment 15 Chris Murphy 2013-01-02 19:01:31 EST
Created attachment 671770 [details]
anaconda-tb-qjilrm

Still get a crash with 18.38.8-1, libreport says it's a dup of this bug. Attaching a current anaconda-tb.
Comment 16 Adam Williamson 2013-01-03 13:26:09 EST
So per IRC discussion yesterday, this just needed the correct patch to be cherry picked from master to f18-branch. Has someone done that yet?
Comment 17 David Lehman 2013-01-03 13:48:59 EST
Yes. It was cherry-picked and pushed earlier today.
Comment 18 Fedora Update System 2013-01-03 20:25:04 EST
anaconda-18.37.9-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.37.9-1.fc18
Comment 19 Chris Murphy 2013-01-03 21:23:05 EST
anaconda-18.37.9-1.fc18 fixes this bug.
Comment 20 Fedora Update System 2013-01-04 15:29:23 EST
Package anaconda-18.37.9-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.37.9-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0206/anaconda-18.37.9-1.fc18
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2013-01-04 19:27:23 EST
anaconda-18.37.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.37.10-1.fc18
Comment 22 Fedora Update System 2013-01-07 20:20:11 EST
anaconda-18.37.11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.37.11-1.fc18
Comment 23 Chris Murphy 2013-01-07 21:24:57 EST
Still fixed in anaconda-18.37.11-1.fc18.
Comment 24 Fedora Update System 2013-01-08 16:33:35 EST
anaconda-18.37.11-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.