Bug 888090 - [RFE] Implement REST ETag mechanism for certain GET operations.
[RFE] Implement REST ETag mechanism for certain GET operations.
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic, Component-Maven, Performance (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.1
Assigned To: Carlos Munoz
Alex Eng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-17 19:33 EST by Carlos Munoz
Modified: 2013-02-25 23:06 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.1.x
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 23:06:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Munoz 2012-12-17 19:33:22 EST
Implement Etags on the server and java client to save on bandwidth (and possibly time) when repeatedly performing the same GET operation.

The server will need to generate Etag headers whenever it responds to one of the affected GET operations. It should also try to honor Etag headers when provided by the client, returning 304 (Not modified) responses when the client provided Etag matches the server calculated one.

The client should keep a local data store (xml) with any server returned Etags and try to populate the Etag header whenever performing one of the affected GET operations. It should also be able to handle 304 responses meaning nothing has changed since the last request was done.
Comment 3 Alex Eng 2013-01-01 21:36:48 EST
Verified in 
Server 2.1
Client 2.2.0-SNAPSHOT
Common 1.8.6-SNAPSHOT
Comment 4 Alex Eng 2013-01-01 21:37:20 EST
Correction: Client 2.0.2-SNAPSHOT

Note You need to log in before you can comment on or make changes to this bug.