Bug 88815 - kernel BUG at dcache.c:362!
kernel BUG at dcache.c:362!
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-14 11:25 EDT by Michael Hoemmken
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 20:42:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hoemmken 2003-04-14 11:25:48 EDT
Description of problem:
Server hangs up during the night. Pinging from other clients is ok, but thats
all. No Login, no ttys, no ssh ...
/var/log/messages shows:
-------------------------------------------------------------
Apr 10 04:02:09 fs1cilian kernel: Unable to handle kernel paging request at
virtual address 70f7ac06
Apr 10 04:02:09 fs1cilian kernel:  printing eip:
Apr 10 04:02:09 fs1cilian kernel: c0153fb1
Apr 10 04:02:09 fs1cilian kernel: *pde = 00000000
Apr 10 04:02:09 fs1cilian kernel: Oops: 0000
Apr 10 04:02:09 fs1cilian kernel: sg ide-scsi parport_pc lp parport nfsd lockd
sunrpc autofs e1000 iptable_filte
Apr 10 04:02:09 fs1cilian kernel: CPU:    0
Apr 10 04:02:09 fs1cilian kernel: EIP:    0010:[<c0153fb1>]    Not tainted
Apr 10 04:02:09 fs1cilian kernel: EFLAGS: 00010207
Apr 10 04:02:09 fs1cilian kernel:
Apr 10 04:02:09 fs1cilian kernel: EIP is at d_lookup [kernel] 0x61 (2.4.18-14)
Apr 10 04:02:09 fs1cilian kernel: eax: f7eb6dc0   ebx: 70f7abd2   ecx: 00000011
  edx: f7e00000
Apr 10 04:02:09 fs1cilian kernel: esi: 70f7abc2   edi: 00000000   ebp: 2c23f4d5
  esp: d89a3e8c
Apr 10 04:02:09 fs1cilian kernel: ds: 0018   es: 0018   ss: 0018
Apr 10 04:02:09 fs1cilian kernel: Process updatedb (pid: 3154, stackpage=d89a3000)
Apr 10 04:02:09 fs1cilian kernel: Stack: 000c021e f8868e7b dbfae6e0 dbfada60
70f7abc2 f7eb6dc0 f49bd000 00000009
Apr 10 04:02:09 fs1cilian kernel:        f49bd000 f49bd009 00000000 d89a3f48
c014a49b e12feb20 d89a3eec f49bd000
Apr 10 04:02:09 fs1cilian kernel:        c014aae9 e12feb20 d89a3eec 00000000
00000008 00000000 e130b0e0 00000000
Apr 10 04:02:09 fs1cilian kernel: Call Trace: [<f8868e7b>] ext3_lookup [ext3]
0x9b (0xd89a3e90))
Apr 10 04:02:09 fs1cilian kernel: [<c014a49b>] cached_lookup [kernel] 0x1b
(0xd89a3ebc))
Apr 10 04:02:09 fs1cilian kernel: [<c014aae9>] link_path_walk [kernel] 0x3d9
(0xd89a3ecc))
Apr 10 04:02:09 fs1cilian kernel: [<c014b109>] path_lookup [kernel] 0x39
(0xd89a3f0c))
Apr 10 04:02:09 fs1cilian kernel: [<c014b3a9>] __user_walk [kernel] 0x49
(0xd89a3f1c))
Apr 10 04:02:09 fs1cilian kernel: [<c01474ff>] vfs_lstat [kernel] 0x1f (0xd89a3f38))
Apr 10 04:02:09 fs1cilian kernel: [<c0147b5b>] sys_lstat64 [kernel] 0x1b
(0xd89a3f70))
Apr 10 04:02:09 fs1cilian kernel: [<c0120001>] request_resource [kernel] 0x21
(0xd89a3f84))
Apr 10 04:02:09 fs1cilian kernel: [<c010910f>] system_call [kernel] 0x33
(0xd89a3fc0))
Apr 10 04:02:09 fs1cilian kernel:
Apr 10 04:02:09 fs1cilian kernel:
Apr 10 04:02:09 fs1cilian kernel: Code: 39 6e 44 8b 1b 75 e8 8b 7c 24 34 39 7e
0c 75 df 8b 57 4c 85
Apr 10 04:10:11 fs1cilian kernel:  ------------[ cut here ]------------
Apr 10 04:10:11 fs1cilian kernel: kernel BUG at dcache.c:362!
Apr 10 04:10:11 fs1cilian kernel: invalid operand: 0000
Apr 10 04:10:11 fs1cilian kernel: sg ide-scsi parport_pc lp parport nfsd lockd
sunrpc autofs e1000 iptable_filte
Apr 10 04:10:11 fs1cilian kernel: CPU:    0
Apr 10 04:10:11 fs1cilian kernel: EIP:    0010:[<c01538d1>]    Not tainted
Apr 10 04:10:11 fs1cilian kernel: EFLAGS: 00010202
Apr 10 04:10:11 fs1cilian kernel:
Apr 10 04:10:11 fs1cilian kernel: EIP is at prune_dcache [kernel] 0x91 (2.4.18-14)
Apr 10 04:10:11 fs1cilian kernel: eax: 00000040   ebx: cc5cb378   ecx: cc5cb040
  edx: cc5cb3f8
Apr 10 04:10:11 fs1cilian kernel: esi: cc5cb360   edi: d41e27a0   ebp: 000008d8
  esp: c34b1fac
Apr 10 04:10:11 fs1cilian kernel: ds: 0018   es: 0018   ss: 0018
Apr 10 04:10:11 fs1cilian kernel: Process kswapd (pid: 5, stackpage=c34b1000)
Apr 10 04:10:11 fs1cilian kernel: Stack: cc5cb0e0 cc5cb2e0 c34b0000 0000003e
c34b0000 00000000 c34b0245 0008e000
Apr 10 04:10:11 fs1cilian kernel:        c0153d04 0000467f c0136c2e 00000006
000001f0 c1e10018 00010f00 c1e17fb8
Apr 10 04:10:11 fs1cilian kernel:        c0105000 c010744e 00000000 c0136b60
00000000
Apr 10 04:10:11 fs1cilian kernel: Call Trace: [<c0153d04>] shrink_dcache_memory
[kernel] 0x24 (0xc34b1fcc))
Apr 10 04:10:11 fs1cilian kernel: [<c0136c2e>] kswapd [kernel] 0xce (0xc34b1fd4))
Apr 10 04:10:11 fs1cilian kernel: [<c0105000>] stext [kernel] 0x0 (0xc34b1fec))
Apr 10 04:10:11 fs1cilian kernel: [<c010744e>] kernel_thread [kernel] 0x2e
(0xc34b1ff0))
Apr 10 04:10:11 fs1cilian kernel: [<c0136b60>] kswapd [kernel] 0x0 (0xc34b1ff8))
Apr 10 04:10:11 fs1cilian kernel:
Apr 10 04:10:11 fs1cilian kernel:
Apr 10 04:10:11 fs1cilian kernel: Code: 0f 0b 6a 01 82 aa 25 c0 8d 43 f8 8b 48
04 8b 53 f8 89 11 89


Version-Release number of selected component (if applicable):
  Original Kernel from RH8.0, 2.4.18-14

How reproducible:
Happens every night, if "Tapeware" (Backup-Software, www.tapeware.com) and the
updater of "AntiVir" (www.antivir.de) run together. Maybe it's only AntiVir, but
there's not much testing possible, because it's a productive system.


Steps to Reproduce:
1. Tapeware as daemon in memory (not doing backup)
2.  Updater of AntiVir (active, getting new Antivirus-Files)
3.
    
Actual results:
Stopping Antivir-Updater and symptom does not appear.

Expected results:


Additional info:
Comment 1 Arjan van de Ven 2003-04-16 05:39:18 EDT
please upgrade to the latest available erratum kernel first;
also make sure that you are not backing up the /dev directory; a lot of backup
software makes wrong assumptions there and assumes that open of files there
doesn't have side-effects.

Note You need to log in before you can comment on or make changes to this bug.