Bug 888150 - [Project-wide search replace] Case sensitive search should return case sensitive results
[Project-wide search replace] Case sensitive search should return case sensit...
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity high
: ---
: 2.1
Assigned To: David Mason
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-18 01:19 EST by Ding-Yi Chen
Modified: 2013-02-25 23:06 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.1-SNAPSHOT (20121220-0033)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 23:06:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-12-18 01:19:04 EST
Description of problem:

It is expected to get case sensitive search result when "Case sensitive" is checked. However, zanata still return case insensitive results.

Version-Release number of selected component (if applicable):
Zanata version 2.1-SNAPSHOT (20121217-1536)

How reproducible:
Always

Steps to Reproduce:
1. Visit any document
2. On entry 1, type "Test"
3. On entry 2, type "test"
4. Click at project wide search and replace icon and enter the search mode
5. Search scope set to either "both" or "Target"
6. Check "Case sensitive"
7. Search "test"
  
Actual results:
Both "Test" and "test" are returned

Expected results:
Only "test" is returned

Additional info:
Comment 1 David Mason 2012-12-19 00:45:09 EST
Bug is present since 2.0.3
Comment 2 David Mason 2012-12-19 00:46:33 EST
Fixed in 2.1-SNAPSHOT

See: https://github.com/zanata/zanata/commit/8661bd3e9bc5d8e720a7bd24e5fbee6604d32302
Comment 3 Ding-Yi Chen 2012-12-19 18:47:12 EST
VERIFIED with Zanata version 2.1-SNAPSHOT (20121220-0033)

Note You need to log in before you can comment on or make changes to this bug.