Bug 888204 - Alpine included is non-free files (source).
Alpine included is non-free files (source).
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alpine (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joshua Daniel Franklin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2012-12-18 04:32 EST by mejiko
Modified: 2013-01-11 19:45 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-06 22:56:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 641479 None None None Never
GNU Savannah 34215 None None None Never

  None (edit)
Description mejiko 2012-12-18 04:32:33 EST
Hello.

alpine included non free software 
This file is licensed under "non-commercial use only".
It is is non-free. 

Files: (Source RPM is: alpine-2.02-3.fc17.src.rpm)

re-alpine-2.02/pico/msmem.c


Suggests:

1. Remove non-free files.
2. Replace to Fedora-Free file.
3. Remove Fedora repos.

Thanks.
Comment 1 mejiko 2012-12-18 04:35:28 EST
Blocking FE-Legal, This is license problem.
Comment 2 Joshua Daniel Franklin 2012-12-18 08:29:31 EST
Thanks for the report. As it appears msmem.c is only used for the Windows build, I'll get the non-free file removed.

As the code is not used in the Linux binary, I do not see why this should block FE-Legal.
Comment 3 Tom "spot" Callaway 2012-12-18 10:07:42 EST
Agreed. Just remove the non-free file from the source tarball and make a "clean" tarball, this will resolve the issue.
Comment 4 Rex Dieter 2012-12-18 10:19:36 EST
the file in question should still be redistributable,  so why the need to remove it?
Comment 5 mejiko 2012-12-19 07:54:29 EST
(In reply to comment #4)
> the file in question should still be redistributable,  so why the need to
> remove it?

This file is licensed under "non-commercial" use only. (This license is not allow use any purpose, including commercial use, commercial redistribute, etc...)

Its not OK.
Comment 7 Tom "spot" Callaway 2012-12-19 10:35:07 EST
There is enough of a gray area here as to whether distribution of that code could fall into the area of commercial use that I'd rather be safe than sorry.
Comment 8 Joshua Daniel Franklin 2012-12-20 09:35:02 EST
I'm going to do an update, but can't right now due to other responsibilities. Soon though.
Comment 9 Fedora Update System 2012-12-21 07:47:33 EST
alpine-2.03-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/alpine-2.03-2.fc18
Comment 10 Fedora Update System 2012-12-21 07:59:38 EST
alpine-2.03-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/alpine-2.03-2.fc17
Comment 11 Fedora Update System 2012-12-21 08:04:20 EST
alpine-2.03-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/alpine-2.03-2.el6
Comment 12 Fedora Update System 2012-12-21 09:02:00 EST
alpine-2.03-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/alpine-2.03-1.el5
Comment 13 Fedora Update System 2012-12-21 09:03:28 EST
alpine-2.03-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/alpine-2.03-2.fc16
Comment 14 Joshua Daniel Franklin 2012-12-21 09:10:10 EST
Updates pushed, please test and provide Karma.
Comment 15 Fedora Update System 2012-12-21 15:05:19 EST
Package alpine-2.03-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing alpine-2.03-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20835/alpine-2.03-2.fc18
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-01-06 22:56:39 EST
alpine-2.03-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-01-07 02:27:52 EST
alpine-2.03-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-01-10 19:57:51 EST
alpine-2.03-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-01-10 19:58:50 EST
alpine-2.03-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2013-01-11 19:45:00 EST
alpine-2.03-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.