Bug 888214 - VDSM crashes immediately after starting if vdsm.log is missing
VDSM crashes immediately after starting if vdsm.log is missing
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.2
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.2
Assigned To: Yaniv Bronhaim
Haim
infra
:
Depends On:
Blocks: ovirt-3.2-release
  Show dependency treegraph
 
Reported: 2012-12-18 05:05 EST by Ohad Basan
Modified: 2014-10-30 18:34 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 01:47:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
engine-setup.log (155.36 KB, text/x-log)
2012-12-18 05:05 EST, Ohad Basan
no flags Details
host deploy log (151.14 KB, text/x-log)
2012-12-18 05:05 EST, Ohad Basan
no flags Details

  None (edit)
Description Ohad Basan 2012-12-18 05:05:11 EST
Created attachment 665389 [details]
engine-setup.log

Description of problem:
In an all in one installation on fedora18
right after host-deploy vdsm crashes. 
I'll attach further info if needed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.run all in one installation a fedora18 system
2.host is non responsive and vdsmd is down. 
3.respawning it fails.
  
Actual results:
vdsm is crashing.
Comment 1 Ohad Basan 2012-12-18 05:05:40 EST
Created attachment 665390 [details]
host deploy log
Comment 2 Ohad Basan 2012-12-18 07:09:54 EST
Looks like it fails due to trying to access vdsm.log before it exists.
Comment 3 Moran Goldboim 2012-12-18 09:31:04 EST
blocks ovirt live flow.
Comment 4 Dan Kenigsberg 2012-12-18 15:42:28 EST
http://gerrit.ovirt.org/#/c/10194/
Comment 6 Itamar Heim 2013-01-16 11:10:28 EST
3.2 beta built, moving to ON_QA status to allow testing

Note You need to log in before you can comment on or make changes to this bug.