This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 888258 - libvirtd doesn't restart after vdsm configures it
libvirtd doesn't restart after vdsm configures it
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.2
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.2
Assigned To: Yaniv Bronhaim
Haim
infra
:
Depends On:
Blocks: ovirt-3.2-release
  Show dependency treegraph
 
Reported: 2012-12-18 07:12 EST by Ohad Basan
Modified: 2014-10-30 18:34 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-15 01:47:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
engine-setup.log (155.36 KB, text/x-log)
2012-12-19 04:16 EST, Ohad Basan
no flags Details
host deploy log (151.14 KB, text/x-log)
2012-12-19 04:16 EST, Ohad Basan
no flags Details
vdsm.log (24.61 KB, text/plain)
2012-12-19 05:22 EST, Ohad Basan
no flags Details

  None (edit)
Description Ohad Basan 2012-12-18 07:12:23 EST
Description of problem:
After host-deploy libvirtd should be restarted prior to starting vdsmd.
in order for it to load the new configuration


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.install a fedora18 + ovirt nightly.
2.connect a new host.
3.
  
Actual results:
vdsm crashes because libvirtd wasn't restarted before that.

Expected results:
libvirtd should be restarted after being configured.

Additional info:
Comment 1 Moran Goldboim 2012-12-18 09:30:30 EST
blocks ovirt live flow.
Comment 2 Alon Bar-Lev 2012-12-18 16:14:11 EST
Ohad, this is not full description.

You should have written that ovirt-host-deploy executes vdsm reconfigure, this succeeds, and still there is an issue with vdsm/libvirt, even paste the relevant log hank.

You should have come up with Dan analyze of the problem, as he did invest time.
Comment 3 Ohad Basan 2012-12-19 04:16:22 EST
Created attachment 665986 [details]
engine-setup.log
Comment 4 Ohad Basan 2012-12-19 04:16:49 EST
Created attachment 665987 [details]
host deploy log
Comment 5 Dan Kenigsberg 2012-12-19 04:20:08 EST
I am guessing that vdsmd.service failed to restart libvirt after having /etc/libvirtd.conf reconfigured.

You can verify my guess by applying the following untested patch, and rebuild vdsm:

diff --git a/vdsm/vdsmd.init.in b/vdsm/vdsmd.init.in
index 7a7ae84..86edc15 100755
--- a/vdsm/vdsmd.init.in
+++ b/vdsm/vdsmd.init.in
@@ -362,7 +362,11 @@ EOF
 
     ovirt_store_config "$lconf" "$qconf" "$ldconf" "$llogr"
 
-    /sbin/initctl restart libvirtd 2>/dev/null || :
+    if libvirt_should_use_upstart; then
+        /sbin/initctl restart libvirtd 2>/dev/null || :
+    else
+        systemctl reload libvirtd.service
+    fi
 
     #
     # finished reconfiguration, do not trigger
Comment 6 Ohad Basan 2012-12-19 05:22:23 EST
Created attachment 666012 [details]
vdsm.log

this patch doesn't seem to be working. log is attached.
Comment 7 Yaniv Bronhaim 2012-12-25 08:10:06 EST
merged upstream - http://gerrit.ovirt.org/#/c/10237/
posted for 3.2 branch - http://gerrit.ovirt.org/#/c/10316/
Comment 8 Itamar Heim 2013-01-16 11:10:26 EST
3.2 beta built, moving to ON_QA status to allow testing

Note You need to log in before you can comment on or make changes to this bug.