Bug 888281 - packstack: do not use ping to verify connectivity to hosts
packstack: do not use ping to verify connectivity to hosts
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
2.0 (Folsom)
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Derek Higgins
Nir Magnezi
: Improvement, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-18 07:52 EST by Yaniv Kaul
Modified: 2016-04-26 18:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-29 06:10:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-12-18 07:52:02 EST
Description of problem:
In many enterprises, ICMP is blocked on the data center. Don't rely on it for testing connectivity for the hosts you wish to connect to. If you need SSH, test using SSH.

Version-Release number of selected component (if applicable):
openstack-packstack-2012.2.2-0.1.dev205.el6ost.noarch

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Derek Higgins 2012-12-18 19:29:20 EST
Fix now committed upstream

https://github.com/fedora-openstack/packstack/commit/c849ef7769ec7320a0b81b4bfa50e7b73678801b

now testing ssh port is open and no longer pinging hosts
Comment 4 Nir Magnezi 2013-01-24 04:06:43 EST
Verified With: openstack-packstack-2012.2.2-0.5.dev318.el6ost.noarch

Verification Steps:
1. Configured packstack answers file with the relevant IP Addresses.
2. Stopped sshd service in one of the servers I've listed in packstack answers file.
3. Ran packstack

packstack failed with the following error:

Error: could not connect to the ssh server: <IP Address>
Comment 6 errata-xmlrpc 2013-01-29 06:10:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-0204.html

Note You need to log in before you can comment on or make changes to this bug.