Bug 888292 - Edit LV/RAID dialogs lose focus after "Format?" dialog is shown
Edit LV/RAID dialogs lose focus after "Format?" dialog is shown
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: David Shea
Release Test Team
:
: 884667 (view as bug list)
Depends On:
Blocks: 960065 841211
  Show dependency treegraph
 
Reported: 2012-12-18 08:09 EST by Jan Stodola
Modified: 2013-11-21 04:57 EST (History)
4 users (show)

See Also:
Fixed In Version: anaconda-13.21.198-1
Doc Type: Bug Fix
Doc Text:
Cause: When re-using an existing partition without choosing to format the partition, a confirmation dialog is displayed asking the user whether to modify the settings for the partition or to use it as configured and do not format. If "Modify Partition" is selected to return to the edit dialog, no dialog will have focus. Consequence: Unexpected loss of window focus requiring the user to click a dialog with the mouse in order to continue. Fix: Correct the parent window setting when creating new dialogs to ensure that focus always returns to the previous window when a dialog completes. Result: Focus correctly returns to previous dialog window.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 04:57:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2012-12-18 08:09:56 EST
Description of problem:
When user reuse existing partition without creating new file system, warning dialog is shown:

"You have chosen to use a pre-existing partition for this installation without formatting it. ..."

After selecting "Modify Partition", no window has focus.


Version-Release number of selected component (if applicable):
anaconda-13.21.190

How reproducible:
always

Steps to Reproduce:
1. install system, make sure that / is on LVM or RAID
2. start new installation in graphical mode
3. proceed to custom partitioning
4. edit "/" LV/RAID from previous installation 
5. select "/" mount point and click OK
6. anaconda asks to format pre-existing partition - select "Modify Partition"
  
Actual results:
No window has focus

Expected results:
Edit LV/RAID window has focus

Additional info:
Tested with LVM/RAID partitioning. When reusing existing native partition without formatting, anaconda doesn't ask to format the partition (bug 886020).
Comment 4 Brian Lane 2013-07-23 12:44:52 EDT
*** Bug 884667 has been marked as a duplicate of this bug. ***
Comment 6 Ľuboš Kardoš 2013-09-04 07:03:28 EDT
Verified on RHEL6.5-20130830.2, anaconda 13.21.204
Comment 8 errata-xmlrpc 2013-11-21 04:57:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1588.html

Note You need to log in before you can comment on or make changes to this bug.