Bug 888292 - Edit LV/RAID dialogs lose focus after "Format?" dialog is shown
Summary: Edit LV/RAID dialogs lose focus after "Format?" dialog is shown
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: David Shea
QA Contact: Release Test Team
URL:
Whiteboard:
: 884667 (view as bug list)
Depends On:
Blocks: 960065 841211
TreeView+ depends on / blocked
 
Reported: 2012-12-18 13:09 UTC by Jan Stodola
Modified: 2013-11-21 09:57 UTC (History)
4 users (show)

Fixed In Version: anaconda-13.21.198-1
Doc Type: Bug Fix
Doc Text:
Cause: When re-using an existing partition without choosing to format the partition, a confirmation dialog is displayed asking the user whether to modify the settings for the partition or to use it as configured and do not format. If "Modify Partition" is selected to return to the edit dialog, no dialog will have focus. Consequence: Unexpected loss of window focus requiring the user to click a dialog with the mouse in order to continue. Fix: Correct the parent window setting when creating new dialogs to ensure that focus always returns to the previous window when a dialog completes. Result: Focus correctly returns to previous dialog window.
Clone Of:
Environment:
Last Closed: 2013-11-21 09:57:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1588 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2013-11-21 00:40:22 UTC

Description Jan Stodola 2012-12-18 13:09:56 UTC
Description of problem:
When user reuse existing partition without creating new file system, warning dialog is shown:

"You have chosen to use a pre-existing partition for this installation without formatting it. ..."

After selecting "Modify Partition", no window has focus.


Version-Release number of selected component (if applicable):
anaconda-13.21.190

How reproducible:
always

Steps to Reproduce:
1. install system, make sure that / is on LVM or RAID
2. start new installation in graphical mode
3. proceed to custom partitioning
4. edit "/" LV/RAID from previous installation 
5. select "/" mount point and click OK
6. anaconda asks to format pre-existing partition - select "Modify Partition"
  
Actual results:
No window has focus

Expected results:
Edit LV/RAID window has focus

Additional info:
Tested with LVM/RAID partitioning. When reusing existing native partition without formatting, anaconda doesn't ask to format the partition (bug 886020).

Comment 4 Brian Lane 2013-07-23 16:44:52 UTC
*** Bug 884667 has been marked as a duplicate of this bug. ***

Comment 6 Ľuboš Kardoš 2013-09-04 11:03:28 UTC
Verified on RHEL6.5-20130830.2, anaconda 13.21.204

Comment 8 errata-xmlrpc 2013-11-21 09:57:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1588.html


Note You need to log in before you can comment on or make changes to this bug.