Bug 888318 - "qdiskd: configuration failed" shown instead of explanatory message
Summary: "qdiskd: configuration failed" shown instead of explanatory message
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster   
(Show other bugs)
Version: 6.4
Hardware: Unspecified Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Christine Caulfield
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-18 13:47 UTC by michal novacek
Modified: 2013-11-21 11:22 UTC (History)
8 users (show)

Fixed In Version: cluster-3.0.12.1-53.el6
Doc Type: Bug Fix
Doc Text:
Cause: qdiskd has an incorrect logging level for the message indicating that the token timeout was incorrect Consequence: If the token timeout was set wrongly in cluster.conf then qdisk just printed the unhelpful message "qdiskd: configuration failed" Fix: Change the message level from DEBUG to ERR Result: If the token timeout is set incorrectly for qdiskd then a more explanatory message: qdiskd: Configuration failed. qdiskd: Token timeout 3000 is too fast to use with qdiskd!" is now printed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 11:22:43 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1617 normal SHIPPED_LIVE cluster and gfs2-utils bug fix update 2013-11-20 21:38:45 UTC

Description michal novacek 2012-12-18 13:47:08 UTC
Description of problem:
Having too short totem timeout stops qdiskd from running which is correct but
what is weird that to get to this fact I needed to run manually qdiskd binary
in debug mode on foreground to find it out. It would be so much better to find
this message in /var/log/messages instead of being forced to debug this way.
"qdiskd: Configuration failed" is really not very helpful in finding out what
caused it to fail.

Version-Release number of selected component (if applicable):
cman-3.0.12.1-46.el6.x86_64

How reproducible: always

Steps to Reproduce:
1/ have a cluster with quorum disk and <totem token="3000" /> and try to start it.
  
Actual results:
Cluster not starting and /var/log/messages saying "qdiskd: Configuration failed"

Expected results:
Having the real cause of the problem in /var/log/messages
qdiskd: Configuration failed.
qdiskd: Token timeout 3000 is too fast to use with qdiskd!

Additional info:
It might be a good idea to just calculate the value needed from given token?

Comment 1 Fabio Massimo Di Nitto 2012-12-18 13:51:44 UTC
commit 544a70cbcf94410d277fd7123a1943c8d2bef790
Author: Fabio M. Di Nitto <fdinitto@redhat.com>
Date:   Tue Dec 18 14:50:43 2012 +0100

    qdiskd: change log level for an error message
    
    Resolves: rhbz#888318
    
    Signed-off-by: Fabio M. Di Nitto <fdinitto@redhat.com>


agreed and fixed.

out of all errors in that code path, that message was the only one at LOG_DEBUG.

Comment 10 errata-xmlrpc 2013-11-21 11:22:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1617.html


Note You need to log in before you can comment on or make changes to this bug.