Bug 88833 - Requires libwrap.so.0 which may lie on a NFS partition
Summary: Requires libwrap.so.0 which may lie on a NFS partition
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: portmap (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-14 18:48 UTC by Enrico Scholz
Modified: 2015-01-08 00:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-12 18:37:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2003-04-14 18:48:21 UTC
Description of problem:

portmap requires files from /usr/lib which may be outside the root-partition:

| $ ldd /sbin/portmap 
|        libwrap.so.0 => /usr/lib/libwrap.so.0 (0x40031000)

When having an NFS-mounted /usr directory, the booting fails because portmap
(which is required by NFS) can not be started.


Version-Release number of selected component (if applicable):

tcp_wrappers-7.6-34
portmap-4.0-54


How reproducible:

100%


Steps to Reproduce:
1. mount /usr via NFS
2. reboot

Actual results:

Starting portmapper: portmap: error while loading shared libraries:
libwrap.so.0: cannot open shared object file: No such file or directory
...
Mounting NFS filesystems: <<< MACHINE HANGS >>>


Expected results:

portmapper will be started and NFS filesystems will be mounted.

Comment 1 Steve Dickson 2004-08-12 18:37:37 UTC
portmap now statically links with libwrap


Note You need to log in before you can comment on or make changes to this bug.