Bug 88836 - "Exception occurred" error when selecting the rhn icon
"Exception occurred" error when selecting the rhn icon
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Depends On:
  Show dependency treegraph
Reported: 2003-04-14 15:29 EDT by Brad
Modified: 2007-04-18 12:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-23 18:20:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brad 2003-04-14 15:29:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
After booting 9, the rhn icon turns into a grey question-mark. If I hold my
mouse cursor over it, it displays "Error connecting to RHN...". If I single or
double click on it, I get this error:

An unhandled exception error has occurred. this is most likey a bug. etc etc
Exception type exceptions.IOError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet.py", line 448, in refresh
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_model.py", line 264, in refresh
  File "/usr/bin/../share/rhn/rhn_applet/rhn_applet_rpc.py", line 84, in refresh
    status = server.applet.poll_status()
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 126, in _request
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 130, in request
    headers, fd = req.send_http(host, handler)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 612, in send_http
  File "/usr/lib/python2.2/site-packages/rhn/connections.py", line 203, in connect
    response = HTTPConnection.getresponse(self)
  File "/usr/lib/python2.2/site-packages/rhn/connections.py", line 103, in
  File "/usr/lib/python2.2/site-packages/rhn/connections.py", line 176, in begin
  File "/usr/lib/python2.2/httplib.py", line 269, in begin
    version, status, reason = self._read_status()
  File "/usr/lib/python2.2/httplib.py", line 231, in _read_status
    line = self.fp.readline()
IOError: [Errno 104] Connection reset by peer

I also get the standard "Red Hat Network Registration" dialog box:

"Your system does not appear to be registered with the Red Hat Network..." etc.
etc. and I get to select the "Register with RHN" click box. If I select "Cancel"
and then close the "Exception occurred" error box (from above), the rhn icon
turns to a blue tick and if I hold my mouse over it I get "Waiting before
checking". And then it turns to a grey question mark again.

While it is a blue tick, if I right-click it and select "Configuration", it
brings up the "Red Hat Network Alert Notification Tool" box. I click "Forward"
to "Terms Of Service" and then "Forward" to "Proxy Configuration", I see that my
proxy address is in there (I am a networked PC with a RH7.3 proxy server
connected to the Internet) but the "Enable HTTP Proxy" box is not ticked. I tick
it and then "Forward" and then "Apply" and the dialog closes and the rhn applet
icon turns to a double-headed green arrow for a few seconds and then turns to a
grey question mark again.

If I then repeat the above process and check the "Proxy Configuration" again, it
is exactly the same, with the "Enable HTTP Proxy" box un-ticked.

When get the standard "Red Hat Network Registration" dialog:

"Your system does not appear to be registered with the Red Hat Network..." etc.
etc. and I select the "Register with RHN" click box, it takes me through a few
steps to "Step 1: Review the Red Hat Privacy Statement", but this never comes
up. If I select "Forward" anyway and go through and complete all the forms to
"Send Profile Information to Red Hat Network", I get "Problem registering
username" and can go no further.

It seems that some of these troubles are caused by the inability of my PC to
contact the RHN, probably due to the "Enable HTTP Proxy box un-ticked" problem
listed above.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. See description

Additional info:
Comment 1 Daniel Veillard 2003-04-14 17:49:22 EDT
You seems to have some networking troubles leading to the problem to connect
to the RHN service. Try te following command at the shell prompt, then
wait for the escape message hit the return key a could of time and wait
for the disconnection:

paphio:~ -> telnet www.rhns.redhat.com 443
Connected to www.rhns.redhat.com.
Escape character is '^]'.
Connection closed by foreign host.
paphio:~ ->

  If you can't get to the "Escape character is..." message then check with 
your network administrator or ISP you have a problem connecting. If this
works  try to launch the applet again this may have been a temporary error.

Comment 2 Brad 2003-04-14 20:37:10 EDT
I have browse, telnet, use news, ftp with no problems, and here is the result of
your test:

# telnet www.rhns.redhat.com 443
Connected to xmlrpc.rhn.redhat.com (
Escape character is '^]'.

Connection closed by foreign host.

The problem has occurred every time that I have tried since installing 9. It
worked perfectly with 8.0. It was a fresh install of 9. Does the fact that the
"Enable HTTP Proxy" box is being un-ticked mean anything?
Comment 3 Daniel Veillard 2003-04-15 05:18:17 EDT
"Enable HTTP Proxy" should not be activated unless your network environment
requires HTTP or HTTPS connexions to go through a proxy. Ask your network
administrator or your ISP about it.
The up2date and applet cannot contact the server. That's the reason of the
problem. I have no idea why, nor any way to reproduce your problem especially
if a direct connection to the server port seems to work. Without a way to
reproduce the problem or understand better what is happening in your specific
case, there is no way I can guess what is happening in your case.


Comment 4 Todd Warner 2005-09-23 18:20:14 EDT
2 years since a reponse. Closing.

Note You need to log in before you can comment on or make changes to this bug.