Bug 888378 - Check box "Disconnected RHN Satellite" has no effect.
Check box "Disconnected RHN Satellite" has no effect.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
550
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Michael Mráka
Martin Minar
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2012-12-18 10:24 EST by Dimitar Yordanov
Modified: 2016-07-03 20:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:55:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2012-12-18 10:24:43 EST
Description of problem:
Check box "Disconnected RHN Satellite" located in tab: 
 Admin ->  RHN Satellite Configuration ->  General
has no effect.

Version-Release number of selected component (if applicable):
Satellite [541|550]

How reproducible:
100%

Steps to Reproduce:
1. Have a RHN Satellite [541|550] with "Disconnected RHN Satellite" unchecked.

===> Disconnected RHN Satellite -> Unchecked

# grep  server.satellite.rhn_parent /etc/rhn/rhn.conf
server.satellite.rhn_parent = satellite.rhn.redhat.com
server.satellite.rhn_parent = satellite.rhn.redhat.com

2. Go to tab Admin ->  RHN Satellite Configuration ->  General
and check: "Disconnected RHN Satellite"

===> Disconnected RHN Satellite -> Checked

3. Restart Satellite 
# rhn-satellite restart
Shutting down spacewalk services...
Stopping RHN Taskomatic...
Stopped RHN Taskomatic.
Stopping cobbler daemon: [  OK  ]
Stopping rhn-search...
Stopped rhn-search.
Stopping MonitoringScout ...  
[ OK ]
Stopping Monitoring ...  
[ OK ]
Shutting down osa-dispatcher: [  OK  ]
Stopping httpd: [  OK  ]
Stopping tomcat6: [  OK  ]
Shutting down Oracle Net Listener ...[  OK  ]
Shutting down Oracle DB instance "rhnsat" ...[  OK  ]
Terminating jabberd processes ...
Stopping s2s: [  OK  ]
Stopping c2s: [  OK  ]
Stopping sm: [  OK  ]
Stopping router: [  OK  ]
Done.
Starting spacewalk services...
Initializing jabberd processes ...
Starting router: [  OK  ]
Starting sm: [  OK  ]
Starting c2s: [  OK  ]
Starting s2s: [  OK  ]
Starting Oracle Net Listener ... [  OK  ]
Starting Oracle DB instance "rhnsat" ... [  OK  ]
Starting tomcat6: [  OK  ]
Waiting for tomcat to be ready ...
Starting httpd: [  OK  ]
Starting osa-dispatcher: [  OK  ]
Starting Monitoring ...  
[ OK ]
Starting MonitoringScout ...  
[ OK ]
Starting rhn-search...
Starting cobbler daemon: SERVING!
[  OK  ]
Starting RHN Taskomatic...
Done.

Actual results:

# grep  server.satellite.rhn_parent /etc/rhn/rhn.conf
server.satellite.rhn_parent = satellite.rhn.redhat.com
server.satellite.rhn_parent = satellite.rhn.redhat.com

# satellite-sync -l
05:17:18 Red Hat Network Satellite - live synchronization
05:17:18    url: https://satellite.rhn.redhat.com
05:17:18    debug/output level: 1
05:17:19    db:  rhnsat/<password>@//localhost:1521/rhnsat.world
05:17:19
05:17:19 Retrieving / parsing channel-families data
05:17:22 channel-families data complete
05:17:22
05:17:22 Retrieving / parsing product names data
^C
User interrupted process.
  



Expected results:

The value of server.satellite.rhn_parent in /etc/rhn/rhn.conf is dismissed.
satellite-sync  does not work.


Additional info:
Comment 1 Tomas Lestach 2012-12-18 11:15:49 EST
I see the 'Disconnected RHN Satellite' box checked.

# grep disconnected /etc/rhn/rhn.conf 
disconnected=1                

After unchecking the ckeckbox I see

grep disconnected /etc/rhn/rhn.conf                                
disconnected=0                                               

This issue does not seem to be in WebUI. Reseting to Satellite Synchronization component.
Comment 2 Michael Mráka 2013-05-10 07:51:41 EDT
Fixed in spacewalk master by
commit 1bf057e0c697c66c604287b9eba9a2b0e33969db
    888378 - print nice error message in disconnected mode
Comment 4 Clifford Perry 2013-10-01 17:55:55 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.