Bug 88842 - dvipdfm segfaults
Summary: dvipdfm segfaults
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: tetex   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-14 19:56 UTC by Sammy
Modified: 2007-04-18 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-24 14:23:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Small TeX file with figure (7.18 KB, text/plain)
2003-04-15 14:53 UTC, Sammy
no flags Details
Included eps file (1.24 KB, text/plain)
2003-04-15 14:54 UTC, Sammy
no flags Details
New patch file (730 bytes, patch)
2003-04-15 18:28 UTC, Sammy
no flags Details | Diff

Description Sammy 2003-04-14 19:56:16 UTC
The executable dvipdfm (which is used by kdvi from kegraphics package) 
segfaults when run on a dvi file containing embedded eps figures. It runs 
ok when the document contains no figures. I am at the latest rawhide level 
as of 4-14-2003.

Comment 1 Sammy 2003-04-15 14:53:38 UTC
Created attachment 91141 [details]
Small TeX file with figure

Comment 2 Sammy 2003-04-15 14:54:40 UTC
Created attachment 91142 [details]
Included eps file

Any eps file would do!

Comment 3 Sammy 2003-04-15 15:59:11 UTC
I have built the dvipdfm-0.13.2c-1.i386.rpm from its source and installed 
it over tetex and this one does not crash with any eps file. I could not 
figure out though what the difference is between the two. 

Comment 4 Sammy 2003-04-15 18:27:30 UTC
The culprit seems to be tetex-2.0.2-dvipdfm-security.patch. I am not an expert in 
mkstemp but looking at other examples made a new patch, which does not segfault. 
This is attached below. 

Comment 5 Sammy 2003-04-15 18:28:12 UTC
Created attachment 91145 [details]
New patch file

Comment 6 Tim Waugh 2003-04-24 14:23:35 UTC
Next build will contain the fix.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.